Menu Text not displaying on Games [Solved]

If you need any help with XBMC4XBOX, such as installing or using the software, please post it in here.
Post Reply
Posts: 11
Joined: Sat Feb 09, 2019 9:20 am

Menu Text not displaying on Games [Solved]

Post by kdub24 » Sat Feb 09, 2019 9:57 am

MY Xbox Setup
v1.1 TSOP 2TB HDD with a SATA to IDE adaptor
Games ripped on HDD
latest version of XBMC4Gamers dash
Original AV Composite

The Problem

Some games will not display the in game menu captions/menu text.
I first though it was just a bad rip but after trying multiple different rips same issue.
I also tried clearing the Cache but it didn't fix it.
One of the games is Jurassic Park Operation Genesis.
I tried a NTSC and PAL version but same issue.
I also tried booting from different dashboards and from file explore but same issue.
I have been looking all over to see if anyone else has the same issue but couldn't find anything.

Thank you for any help or suggestions.
Last edited by kdub24 on Fri Feb 15, 2019 3:27 am, edited 2 times in total.

Posts: 318
Joined: Thu Mar 19, 2015 4:01 am
Has thanked: 43 times
Been thanked: 37 times

Re: Menu Text not displaying on Games

Post by Coldly-Indifferent » Sat Feb 09, 2019 2:15 pm

Sounds weird - you are talking about the in game menus having the problem, not XBMC4Gamers or other dashboard menus?

What other games (PAL/NTSC) display with this problem?

Are you using a AV Composite cable or Component cable? I doubt it matters as regards this problem but it is not clear; "RBY" is a confusing description as it could mean any one of three different types: RGB, YPbPr, AV(Y + W/R).

Main dash resolution settings?

How are the games installed ie. from original disc, backup disc or downloaded and FTPed direct? Did you use DVD2Xbox for the disc installation or use it to patch it once installed?

If you have the original disc does the same problem occur when playing from the disc?

A screenshot might be useful to understand the precise nature of the problem.

Posts: 11
Joined: Sat Feb 09, 2019 9:20 am

Re: Menu Text not displaying on Games

Post by kdub24 » Sat Feb 09, 2019 10:58 pm

Thank you for your reply.
Sorry for my lack of clarity in my original post. I posted real late last night.
Im not sure why I put RBY. Im using the AV Composite cable.
My dash resolution is set to Auto I tried NTSC 4:3
The dashboard is displaying properly but the in game menu on a few games are lacking any text. I will attach a picture for clarity.
The games are Downloaded and FTP'ed to the xbox. I have hundreds of games on my HDD and only a couple of the games I have tested have had menu issues. I first thought it was a bad download but I found and tried multiple different downloads and they all have the same menu issues. Halo 2 NTSC was the other game that I experienced to have the same menu issue but I happened to have a copy and used DVD2Xbox to rip it to the hdd and now it has no menu issues.
I wonder if anyone else has had this issue and found a solution?
I found a youtube video of someone playing Jurassic Park Operation Genesis and took a screenshot of the menu with no issues
Screen Shot 2019-02-09 at 1.23.54 PM.png
Thanks again for any help and or suggestions

Posts: 318
Joined: Thu Mar 19, 2015 4:01 am
Has thanked: 43 times
Been thanked: 37 times

Re: Menu Text not displaying on Games

Post by Coldly-Indifferent » Sun Feb 10, 2019 2:03 pm

It worries me that you've said you have hundreds of games on the HDD and you're using a 2TB HDD. Please tell me that F:\ and G:\ were correctly formatted for equal space. They should both be exactly the same total size, <1GB. If you are not sure use XBPartioner v1.3 to check; just to check, do not reformat. If either show an E (Error) in regard to cluster size, which should be 64KB, you have a big problem.

Weird little errors can start occurring if you've used the wrong cluster size once the total size of the folders/files on that particular drive exceed 512GB if it was, for example, formatted to use 32KB clusters.

If it is not that, and I hope it is not, I can't see how this can be anything to do with the Xbox's hardware or even dash you're using. It is most likely a specific game issue. That information about Halo 2 working from a DVD2Xbox rip but not the original download/install is good evidence of that.

This is an absolute guess, as said I've never seen or read about anything similar, but perhaps a particular file connected with the in-game menu/text display has not FTPed or is missing from the original download.

The problem with downloading backup copies of games is that you do not know how they were done. There's a good chance that the same download has been copied and used on multiple sites with the same fault.

However I'd be more inclined to it just being a FTP issue and I'd be comparing the original download folders/files with what is actually on your Xbox. Even if they are exactly the same number then it could just be a file has corrupted or been renamed by XBMC during the transfer and in this case that has had this niche effect on the way the game displays.

Did you copy the zipped/RARed game downloads with this problem to the Xbox unpacked?


I found a download for this game and have just checked the folders/files and it has a lot of .INI files in the Data folder relating to the listing of items, creatures etc in the game. I've not installed it yet but I would not be surprised if more than one or more of those went missing it would cause the problem described.

What FTP client was used? Where there any failed to transfer files you had to retry?

But I reiterate this is all guesswork and somebody else here with wider knowledge may have come across this problem before and be able to supply a better explanation and solution.


Painfully slow stop/start FTP with the .RAR using FileZilla/XBMC dash but it transferred eventually. FTPing the unpacked .RAR was a similarly slow stop/start experience with over 50 files (a mix of those .ini, .tml, .wav and some others) failing to transfer first time. Requeued they all transferred perfectly - typical when using FileZilla.

Interesting thing - the .RAR refused even to open with XBMC v3.5.3 so it could not be unpacked. UnleashX was slightly better but failed with an error message after six items. This is typical when the .RAR or .ZIP contains files with FATX unsupported characters or a file path that exceeds the FATX limit (42). The latter was the case.

I unpacked the incorrectly packed .RAR and using 7Zip repacked it correct as a .ZIP. That transferred faster and smoother and unpacked perfectly on the Xbox.

I've tested both the unpacked FTP game and the FTP zipped then unpacked games separately and as far as I've tested it plays fine, certainly no text display problems.

There should be two folders: Data and Media plus one file: default.xbe although if your download has at any point been patched by DVD2Xbox it with have an additional default.xbe_org too. The Media folder contains two files but it is the Data folder where, if there is something missing/corrupt, it is most likely to be. That contains
46 items: 10 folders and 36 files which make up the bulk of the game, about: 1075MB.
Last edited by Coldly-Indifferent on Mon Feb 11, 2019 2:44 pm, edited 1 time in total.

Posts: 11
Joined: Sat Feb 09, 2019 9:20 am

Re: Menu Text not displaying on Games

Post by kdub24 » Mon Feb 11, 2019 6:55 am

Thank you for all your help!

My 2TB HDD is separated into F: and G: drives that are both 927GB and 64kb Clusters.
I checked with XBPartioner v1.3 and it showed no Errors
Im using FileZilla to FTP to my Xbox and I unzip it before FTPing.
There was no failed to transfer errors. All the files look like they are there and not corrupted.
46 items 10 Folders and 36 items
How do you FTP zipped files and unzip them on XBMC?
I think these .ini files within the GUI folder are the ones that control the menu display.
Not sure why they are not displaying..
The only thing I can think is that its not being put into Cache or something like that..
My E: drive looks a little low on space do you think that could affect the cache?
Also I noticed that I have a second cache called CACHEGSRV
I have tried multiple different downloads from different places and even downloaded a couple iso's
and used qwix to unload the iso and that didnt work. I also tried the same unzipped game on another
v1.6 softmodded xbox and it still had the menu issues. I can only figure that it has something to do with
the .ini file not being loaded into the cache or something like that.. I have tested 30+ games and only
Halo 2 and Jurassic Park have had menu issues. This has been a very frustrating. I have been trying to
put together a complete set of USA xbox games on my xbox. I used Arcade Punks for the complete set and
any that didnt work I found of xbox360iso.
Thanks again for your help and hopefully we can figure out what is causing this menu issue.

Posts: 318
Joined: Thu Mar 19, 2015 4:01 am
Has thanked: 43 times
Been thanked: 37 times

Re: Menu Text not displaying on Games

Post by Coldly-Indifferent » Mon Feb 11, 2019 2:42 pm

Obviously it is not a HDD formatting issue so that is very good news.

Problem is now finding where the problem is in the game and why it should apparently repeat for what you'd think must be different downloads which are unlikely all to be suffering the same fault, if that is what it is.

Sorry I should or may have asked this earlier or not but what version Xbox and video encoder (Conexant, Focus, Xcalibur) are you using? I can test the game easily on another, softmodded, Xbox with Contexant and somewhere in storage I have a Focus softmodded machine too.

I suppose I should also ask what BIOS your TSOP is using too but if there is any possibility of that causing this niche issue I have no idea but the info might be helpful for others.

Have you tried burning the Jurasic Park OG ISO to disc (DVD-R using ImgBurn), test playing that from the disc then and then installing it using DVD2Xbox similar to what was done for Halo 2?

There's no reason to think this will work because the download I tested worked fine without any DVD2Xbox ACL (Access Control List) or other patching although, of course, I have no idea what was done to the original files provided. Anyway this problem is not like any ACL issue I've ever encountered; in my experience the game either plays or does not display correctly on boot.

However we have to test all possibilities: so before wasting any blank media you could try DVD2Xbox patching the installed game just to check this. Launch DVD2Xbox > File Manager > the specific game's folder. Highlight that folder and then press the controller's White button to bring up the context menu. Select "Process ACL" and when you press the (A) button it should show an ACL processing message. Once done check the game's folder. You should now have a "default.xbe" which is the newly ACL patched one and the old unpatched one "default.xbe_org".

Reboot and from the XBMC file manager launch the game from that "default.xbe". If it was an ACL issue then the game should display without the text problem.

BTW I have been testing this on a Xecuter 2.6 chipped v1.6 (BIOS probably Evox M8plus_16) with the Xcalibur video encoder at 480p using the MS Xbox Component cable. So if anyone else here might be thinking of suggesting it may be a Xcalibur display issue that is pretty good evidence it is not.

Short of trying one of the same download(s) you used which would either eliminate or confirm that as the source of the problem (NB. the forum/mods will not allow links to be posted) I'm not sure how we can identify what may be either missing or corrupted.

There are 10 folders with sub-folders too which contain most of the 4000+ individual files that make up the game. Unless someone can help identify the particular .INI or other file that controls the in-game menus text display it is like hunting for a needle in a haystack.

RE: Other Questions

1). XBMC will unZIP and unRAR(?) files via the file manager. I'm not 100% sure about .rar as I do not often unpack stuff using XBMC (prefer UnleashX) but it definitely unpacks .zip. No Xbox dash will unpack the popular .7z format though. There is a lot of Xbox stuff archived with 7Zip using its .7z rather than .zip format (which, of course 7Zip also supports). I've read plenty of cases where people have made the mistake of copying .7z folders to their Xbox and then complaining about not being able to open them. :)

If you click on a compressed archive it will usually display the contents. Select all those contents and copy them to a new folder and it unpacks them as part of the copying process. This is a bit crude compared to UnleashX's file manager's unpacking options. I've had stuff which UnleashX refused to unpack due to FATX character/file path matters which XBMC unpacked without issue because it can rename some troublesome files on the fly.

UnleashX will also ZIP archive files/folders but not RAR them as that is a copywrited process. I've never tried zipping with XBMC but even if the reverse process works there are no menu options. You would have to have a previously zipped folder to add the files too. Again, UnleashX is the preferable tool.

2). E:\ is a bit low. The recommendation is to leave 10% free but at least 100MB. You have more than that so should be OK.

Additional game files are usually written to the X, Y and Z drive which are not displayed in the XBMC file manager by default. Low E:\drive space and cache issues certainly cause problems but not, that I've read about, anything like this.

You could always try deleting or moving some stuff on E:\ to test that. If you have any games in "games" or apps that are taking up a lot of space on E:\ then those are the obvious things. HexIns needs to be left on the root of the E:\ drive as unfortunately it was written to be used just from there.

3). No idea what that CACHEGSRV is but unless it contains something clearly related to JPOG then I wouldn't worry about it. It is probably from an Emulator or Homebrew game some of which write stuff to the root of the E:\ drive no matter where they were installed.

Posts: 11
Joined: Sat Feb 09, 2019 9:20 am

Re: Menu Text not displaying on Games

Post by kdub24 » Fri Feb 15, 2019 3:26 am

Thank you for all the help and suggestions on trouble shooting.

I Solved the in game menu not displaying issue

I don't know why but when uncompressing on my Desktop running Ubuntu it occasionally would
give me the in game menu display issue or would make the games boot to black screen. I tried uncompressing the file(s) with my laptop
running windows and found the menu and game working perfectly. I have been testing the games to see
how many have this issue or boot to black screen and its about 1 in 20+ games. I have no idea why linux would have
issues uncompressing some files and no problem with others. I never received any errors when uncompressing any files.
Most of the files were .7z but I still had the same issue with .rar files when I kept trying multiple copies of Jurassic Park.

Thanks for the education on uncompressing files on XBMC or Unleashed. I made the mistake of FTPing a .7z file and trying to
uncompressing it.

I have been trying to patch ACLs on Dvd2Xbox and it seems to not do much. I am not seeing a default.xbe_org after Processing the ACL.
The games I'm processing the ACL's on are already on my HDD. Games straight ripped from disk seem to have the ACL patched. Do I need to download more ACL files or should the stock ones be enough?

One last question.. Do you know how to fix games that have file names that are too long?
I have seen a couple posts on playing ISO's on HDD is that the way people get around file names being too long?

Thanks again and sorry for asking so many questions

Posts: 318
Joined: Thu Mar 19, 2015 4:01 am
Has thanked: 43 times
Been thanked: 37 times

Re: Menu Text not displaying on Games [Solved]

Post by Coldly-Indifferent » Fri Feb 15, 2019 2:38 pm

Glad you found what the problem was. I don't think there is much chance anyone else here could have known what it was as it sounds very niche.

If you only have the stock and the few (<20) ACL patches you get with a typical DVD2Xbox install it might well do nothing. I would have thought you'd still get the ACL processing message when you clicked Enable ACL Processing even if you only had the basic set. But as I've not tried that myself I might be wrong. My DVD2Xbox installs all have the full 200+ ACL set but if the games are playing OK from the HDD as they are then the ACL patching is not necessary.

Those games included in the basic set are the most commonly encountered ones, like Riddick: Escape From Butcher Bay. Typical, but not universal, symptoms are that the game's opening FMV plays OK but as soon as the game proper loads the picture corrupts. There are other things that can cause similar effects, particularly if you have a v1.6 Xbox, but unless you get a display issue with a particular game do not worry about it.

I've no idea where you'd get the full DVD2Xbox ACL set now anyway. I posted about that here last year:-


BTW the acronym "ACL" I said means: Access Control List. This is what ACL means in general computing terms but since researching this in relation to the Xbox I've seen it stated as being Action Control List and Auto Correct List too. The documentation with the downloads I have offer no definitive meaning.

Most posters just use the acronym without any further explanation but if anyone here knows what "ACL" does actually stand for in this particular context then please share.

Posts: 18
Joined: Mon Jun 06, 2016 1:45 pm
Been thanked: 2 times

Re: Menu Text not displaying on Games [Solved]

Post by kaos_engr » Tue Mar 26, 2019 8:31 am

I found another site that refers to DVD2Xbox's ACL acronym as Auto Correct List.


Post Reply