XBMC not booting, freezing at splash screen

If you need any help with XBMC4XBOX, such as installing or using the software, please post it in here.
Post Reply
miguelfp1
Posts: 7
Joined: Sun Aug 04, 2013 10:39 pm

XBMC not booting, freezing at splash screen

Post by miguelfp1 » Sun Aug 04, 2013 10:41 pm

Hey guys, long-time lurker but first-time poster.

I'm having an issue with XBMC, started about two weeks ago, it won't load on my console, it hangs at the XBMC splash screen.
I've completely removed my XBMC install and tried to start fresh (deleting all the folders inside the install one,
and also deleting the 'face' folders inside TDATA and UDATA), I've tried using the latest nightlies, and also the 3.3 stable,
with the same results.

The log file shows no abnormalities, with the last line being the "initializing playlistplayer", if I recall correctly.
I'm attaching it here.

I've also tried resetting all settings by holding both thumbstick buttons at startup, and that hasn't helped either.

XBMC.log located at: http://pastebin.com/psUW3Byb
XBMC.old.log located at: http://pastebin.com/X2MEE77C

Hopefully, there's enough info there, as I haven't been able to boot into the dash to properly enable debug logging.

Thanks everyone!

whufclee
Posts: 922
Joined: Tue Jul 17, 2012 5:42 pm
Location: Essex, UK
Has thanked: 18 times
Been thanked: 109 times
Contact:

Re: XBMC not booting, freezing at splash screen

Post by whufclee » Sun Aug 04, 2013 11:01 pm

First of all that is a very stange location to have your XBMC installed (F:\Apps\Mediaplayer\xbmc\default.xbe)

That being said I don't see why that would cause any problems unless you've not formatted drive F to the correct cluster size and it's becoming corrupt.

Can I ask why you've installed XBMC on F and not E? E is the perfect size for XBMC and it generally seems to run better from that partition.

User avatar
Dan Dar3
Posts: 1166
Joined: Sun Jul 08, 2012 4:09 pm
Has thanked: 255 times
Been thanked: 251 times
Contact:

Re: XBMC not booting, freezing at splash screen

Post by Dan Dar3 » Mon Aug 05, 2013 12:25 am

I wouldn't be as concerned with the location, but more with the contents at that location.

Press White+Y when XBMC4Xbox boots up to go into recovery mode, that should give you FTP access:
http://www.xbmc4xbox.org.uk/wiki/Error_Recovery_Mode

In there, see if the contents look like what you have in the ZIP archive from which you install it - if missing stuff, extract again on your PC and re-upload through FTP, paying attention to error messages. Q: is a virtual mapping always pointing to the running XBMC4Xbox, wherever that may be (you can see the real location at the top of Q:\xbmc.log), use that to avoid confusing yourself.

I'd recommend an FTP client like FileZilla for say Windows, as it tells you the messages from the server - e.g. free space per drive, or error messages (in red) if running out of space or failure to write (due to network error etc). Best to configure for a single transfer at a time.
https://wiki.filezilla-project.org/Usin ... ed_servers

miguelfp1
Posts: 7
Joined: Sun Aug 04, 2013 10:39 pm

Re: XBMC not booting, freezing at splash screen

Post by miguelfp1 » Mon Aug 05, 2013 1:22 am

First off, thanks for the replies!

As for the location, I think it was one of those Auto-installer discs I used some time back, it put XBMC there and I just kept it in that location.

I use OSX, and I've tried with multiple freshly downloaded copies, but I'll try your suggestion and switch FTP clients to see if there's better luck, I'll also download another fresh copy and try again.

I'll be sure to post as soon as I've tried your suggestions, thanks for your help.

whufclee
Posts: 922
Joined: Tue Jul 17, 2012 5:42 pm
Location: Essex, UK
Has thanked: 18 times
Been thanked: 109 times
Contact:

Re: XBMC not booting, freezing at splash screen

Post by whufclee » Mon Aug 05, 2013 8:27 am

Just to add to that, you are using the compiled build from "b4k3d pi" right? I'm guessing so as you've managed to get as far as the splash screen but if you haven't completely removed the contents of the old xbmc folder I suppose remnants of the old code could still exist that get you as far as a spash screen.

User avatar
xman
Posts: 1288
Joined: Wed Jul 04, 2012 2:30 pm
Location: Sydney, Australia
Has thanked: 55 times
Been thanked: 168 times

Re: XBMC not booting, freezing at splash screen

Post by xman » Mon Aug 05, 2013 11:05 am

You are now seeing why I always suggest to copy a new build to a different location or the same location but with a different name like XBMC2 and then after testing the new build by booting it from filemanager and confirm all is good, boot another app and use that app to edit the names changing XBMC to XBMCold and XBMC to just XBMC. This way you always have an XBMC you can boot and if in the future you do find something with the new build you don't like, you can edit the names back.

miguelfp1
Posts: 7
Joined: Sun Aug 04, 2013 10:39 pm

Re: XBMC not booting, freezing at splash screen

Post by miguelfp1 » Mon Aug 05, 2013 11:11 pm

Here's my status update:

I downloaded a fresh copy of b4k3d pi's compiled 3.3 stable release, switched FTP app and switched the install location to a folder in the E: drive's root. Unfortunately, the issue persists.

Seems my only remaining option is to format the drive and start clean?

whufclee
Posts: 922
Joined: Tue Jul 17, 2012 5:42 pm
Location: Essex, UK
Has thanked: 18 times
Been thanked: 109 times
Contact:

Re: XBMC not booting, freezing at splash screen

Post by whufclee » Tue Aug 06, 2013 6:45 am

How did you try and launch the new xbmc build on the root of e? Did you click the default.xbe in file manager?
Is it doing exactly the same as before when you click the default.xbe?

If so I'm out of ideas and would just use hexen to redo the soft mod, there's absolutely no reason I can think of why this would happen. Did you watch my video guide on how too update via ftp? You'll find it in the tutorial section or on my YouTube channel, its a bit dated now but the procedure is still the same.

miguelfp1
Posts: 7
Joined: Sun Aug 04, 2013 10:39 pm

Re: XBMC not booting, freezing at splash screen

Post by miguelfp1 » Tue Aug 06, 2013 2:20 pm

Hi whufclee,

I tried both launching default.xbe via filemanager, as well as editing the ind-bios.cfg to point to the new location. Both resulted in freezing at the 'XBMC' splash screen.

I'm also completely stumped by the problem, and I've never experienced anything similar in the almost 10 years I've had my console modded (it has a Chameleon chip from waaay back in time).

Certainly, it's the first time I haven't been able to successfully complete an XBMC update.

User avatar
Dan Dar3
Posts: 1166
Joined: Sun Jul 08, 2012 4:09 pm
Has thanked: 255 times
Been thanked: 251 times
Contact:

Re: XBMC not booting, freezing at splash screen

Post by Dan Dar3 » Tue Aug 06, 2013 3:04 pm

@miguelfp1
I wouldn't do anything drastic until you clarify exactly that the two installations you tried (F: and then E:) are in fact complete.

I would transfer the contents back to your PC in a temporary directory, extract the zip in another and use some file / folder compare tool to see if the two have the same contents.

One of the logs stops at loading skin - I would be concerned about that being incomplete, that's what builds the UI.

Also I would try to craft an advancedsettings.xml to enable debug logging at boot time since you can't reach the UI to enable it, maybe that'll reveal more information.
http://www.xbmc4xbox.org.uk/wiki/UserDa ... oglevel.3E

miguelfp1
Posts: 7
Joined: Sun Aug 04, 2013 10:39 pm

Re: XBMC not booting, freezing at splash screen

Post by miguelfp1 » Tue Aug 06, 2013 8:33 pm

Still no go. I downloaded another fresh copy of 3.3 stable, switched to a Windows install instead of OS X, switched to FileZilla, and verified the transfer (it seems that everything is there).
Logs here: XBMC.old.log: http://pastebin.com/2jgbZsm3; XBMC.log: http://pastebin.com/4uPw5kVk

I'm currently downloading the latest nightly (32001) to try again the process.

EDIT: same result with SVN nightly 32001, loading freezes at splash screen. I really don't know what else to try.

Thanks for your patience guys!

sirkingchase
Posts: 15
Joined: Wed Jul 31, 2013 4:32 am

Re: XBMC not booting, freezing at splash screen

Post by sirkingchase » Fri Aug 09, 2013 5:53 am

I have this issue with apps sometimes.

Are you softmodded or using custom bios?

Do you have it on your network?

It seems that if my Xbox is not plugged in a network it hangs. I use dhcp and I think it sits indefinitely waiting. I think this might be the bios I'm using too.

miguelfp1
Posts: 7
Joined: Sun Aug 04, 2013 10:39 pm

Re: XBMC not booting, freezing at splash screen

Post by miguelfp1 » Fri Aug 09, 2013 2:18 pm

I'm using iND-Bios 5003 on a Chameleon modchip, and it's connected to my network. What I'm gonna try sometime today is to see if I can set a different skin via XML, seeing that it apparently hangs while loading the default one.

User avatar
BuZz
Site Admin
Posts: 1889
Joined: Wed Jul 04, 2012 12:50 am
Location: UK
Has thanked: 62 times
Been thanked: 422 times
Contact:

Re: XBMC not booting, freezing at splash screen

Post by BuZz » Fri Aug 09, 2013 4:10 pm

I would start with trying a new bios, and installing on different partition in case it is some fs issue or something. I don't see why it would be skin related. Although I've not seen your particular issue before.

miguelfp1
Posts: 7
Joined: Sun Aug 04, 2013 10:39 pm

Re: XBMC not booting, freezing at splash screen

Post by miguelfp1 » Fri Aug 09, 2013 9:20 pm

Well, I managed to change the skin via XML, and know the log ends with the following lines:
"16:10:13 M: 42967040 ERROR: CVideoDatabase::CreateTables unable to create tables:0
16:10:13 M: 42967040 ERROR: SQLite: Undefined SQLite error
Query: SELECT idVersion FROM version
16:10:13 M: 42967040 FATAL: Unknown exception code (0xe06d7363)
at 0x0031c383"

Full log here: http://pastebin.com/g7es3jJQ

I'm currently leaning towards starting completely from scratch and formatting the HDD, or switching to another streaming box. This issue has me very confused

EDIT: do you recommend any particular BIOS? It's been a while since I've had to flash and configure one on my chip, but I remember I stayed with IND-BIOS just because of the convenience of configuring it via a file, instead of having to reflash.

User avatar
BuZz
Site Admin
Posts: 1889
Joined: Wed Jul 04, 2012 12:50 am
Location: UK
Has thanked: 62 times
Been thanked: 422 times
Contact:

Re: XBMC not booting, freezing at splash screen

Post by BuZz » Fri Aug 09, 2013 10:21 pm

that error makes me think it is a filesystem issue. try another partition first and see.

I like the x2 bios. also has a config file etc.

Dogfyter
Posts: 28
Joined: Mon Jul 23, 2012 11:51 pm
Has thanked: 6 times

Re: XBMC not booting, freezing at splash screen

Post by Dogfyter » Sat Jun 06, 2020 12:51 am

Did you ever find a solve for this issue? If you had xbmc installed in both E and F drives and could not get past the splash screen for either xbmc location then, I have the exact same issue. Did reformatting one drive, whether if it C, E, or F solve it? Thanks in advance for the help.

Post Reply