Buffering issue / cachemembuffersize fixed

Discussion of XBMC4XBOX development.
User avatar
BuZz
Site Admin
Posts: 1890
Joined: Wed Jul 04, 2012 12:50 am
Location: UK
Has thanked: 62 times
Been thanked: 422 times
Contact:

Re: Buffering issue / cachemembuffersize fixed

Post by BuZz »

there is a 4gb limit filesize on fatx, so it will likely break around there.

I don't really recommend file caching - if you are streaming from something that is quick enough it shouldn't be needed.
seriouslycgi
Posts: 89
Joined: Tue Dec 18, 2012 5:35 am
Has thanked: 15 times
Been thanked: 4 times

Re: Buffering issue / cachemembuffersize fixed

Post by seriouslycgi »

this is ideal in our case, we are rural so the connection wont keep up most of the time, ive tried changing modems tried multiple computers and xboxes with different installs and exploits, we have adsl1 7mbit down 1mbit up, nothing else on the line and only about 10 people in our area can use the adsl. we can now pause a show on say 1 channel or movie25 and let it buffer for 10 minutes, then watch the show without it stuttering or failing as it downloads the rest in the background. its awesome.
dan.h
Posts: 140
Joined: Tue May 28, 2013 2:23 pm
Has thanked: 3 times
Been thanked: 10 times

Re: Buffering issue / cachemembuffersize fixed

Post by dan.h »

Cheers for this, can you tweak the advanced settings to buffer from a network share? So for instance, if you wanted a 5mb cache would you have:

Code: Select all

<advancedsettings>
<network>
<alwaysforcebuffer>1</alwaysforcebuffer>
<cachemembuffersize>5242880</cachemembuffersize>
</network>
</advancedsettings>
any real downsides to doing this?
Noo77
Posts: 11
Joined: Tue Oct 29, 2013 3:52 pm

Re: Buffering issue / cachemembuffersize fixed

Post by Noo77 »

Hello, and sorry, this is probably really stupid question, but were do I find the advance settings?
Could some 1 please point me in the right direction
Thanks
skatulskijean
Posts: 1028
Joined: Wed Jul 04, 2012 8:01 am
Has thanked: 1 time
Been thanked: 148 times

Re: Buffering issue / cachemembuffersize fixed

Post by skatulskijean »

Noo77 wrote:Hello, and sorry, this is probably really stupid question, but were do I find the advance settings?
Could some 1 please point me in the right direction
Thanks
The advancedsettings.xml since per default not on xbmc integrated .
You must create a advancedsettings.xml under the userdata Folder .
Only than can it Works
seriouslycgi
Posts: 89
Joined: Tue Dec 18, 2012 5:35 am
Has thanked: 15 times
Been thanked: 4 times

Re: Buffering issue / cachemembuffersize fixed

Post by seriouslycgi »

whufclee wrote:Forgot to mention this but if you want to easily add the advancedsettings.xml for caching to HDD I've added it on my xbmc server. It's easy enough to make a file yourself but if you do want to use the one I made just do the following:

go to filemanager and add a source then type in http://whufclee.myftp.org

In there you'll find a section called TWEAKS and you should find the cache to HDD .xml file in there, just copy to Q:\userdata\

you can download this one ^
Noo77
Posts: 11
Joined: Tue Oct 29, 2013 3:52 pm

Re: Buffering issue / cachemembuffersize fixed

Post by Noo77 »

Thanks for ur help mate,
I've copied the file to Q drive, user data, not getting the message pop up now, but getting a real bad stream very juddery, any ideas mate??
And thanks again ur a star
User avatar
mrmajikbus45
Posts: 344
Joined: Mon Nov 18, 2013 12:36 am
Location: Indianapolis, IN, USA
Has thanked: 32 times
Been thanked: 56 times

Re: Buffering issue / cachemembuffersize fixed

Post by mrmajikbus45 »

Brilliant! I was having stuttering issues, and this seemed to help my issue out. I really want to thank you xphazer and whufclee. This took care of my issue. Girlfriend, the kids, and I watched some Star Trek without a slight hiccup. Thank you!
A strong man doesn't need to read the future, he makes his own. -Solid Snake
American as Guile!
Get your Chimp on!
rigomate
Posts: 1
Joined: Sun Dec 22, 2013 9:01 pm

Re: Buffering issue / cachemembuffersize fixed

Post by rigomate »

I used the advised settings in my advanced settings file.

It did load properly, see log:

Code: Select all

20:54:32 M: 55275520  NOTICE: Loaded advancedsettings.xml from special://profile/advancedsettings.xml
20:54:32 M: 55275520  NOTICE: Contents of special://profile/advancedsettings.xml are...
                                            <advancedsettings>
                                              <network>
                                                <cachemembuffersize>0</cachemembuffersize>
                                              </network>
                                            </advancedsettings>
My xbox is connected over a wifi connection. I am playing a file from a NAS using SMB share.
During file playback I pinged both the xbox and the router doing the wifi bridge. The ping log showed me not one missed package, or extraordinary high latency. The playback did however stop at one point.
See log:

Code: Select all

...
22:13:29 M: 26976256  NOTICE: Creating audio device with codec id: 86018, channels: 2, sample rate: 48000, no pass-through
22:13:29 M: 25202688  NOTICE:  fps: 23.976025, pwidth: 718, pheight: 300, dwidth: 718, dheight: 300
22:13:29 M: 25202688  NOTICE: Display resolution AUTO : PAL 4:3 (6)
22:41:13 M: 20893696   ERROR: XFILE::CSmbFile::Read - Error( Invalid computer name )
Previous line repeats 2 times.
22:41:26 M: 22470656   ERROR: CDVDMessageQueue(video)::Get - asked for new data packet, with nothing available
22:41:26 M: 22470656 WARNING: CDVDMessageQueue(audio)::Get - asked for new data packet, with nothing available
22:41:26 M: 22470656  NOTICE: CDVDPlayer::OnExit()
22:41:26 M: 22470656  NOTICE: DVDPlayer: eof, waiting for queues to empty
22:41:26 M: 22470656  NOTICE: DVDPlayer: closing audio stream
22:41:26 M: 22470656  NOTICE: Closing audio stream
...
I thought If I'd use the option to have the buffer on the hard disk, it would download the entire file while playing it, so if a short hickup in the connection would come, the playback would go on.
Though it seems, if a data packet is not received only once, then the playback stops.

As a side remark.
Using a UTP cable for connection, I never experienced this before.
carpmandanw
Posts: 2
Joined: Thu Jan 16, 2014 6:41 pm

Re: Buffering issue / cachemembuffersize fixed

Post by carpmandanw »

Forum Newb here - a google search led me to this thread.

Great Advise Thank You.

I have Set mine to 0 and it has made a real difference as i was always stuttering before.

I have a couple of questions about this if you don't mind?

Am i right in thinking this caches to the HDD not RAM (Think i read it goes to Z?)

Does it auto clear when its finished, as i don't want to fill the HDD/RAM up.

Thanks Again
User avatar
Dan Dar3
Posts: 1166
Joined: Sun Jul 08, 2012 4:09 pm
Has thanked: 255 times
Been thanked: 251 times
Contact:

Re: Buffering issue / cachemembuffersize fixed

Post by Dan Dar3 »

@carpmandanw
Z: is a partition, you can actually access it through FTP if you want (if not listed in the root, try going to say Q and then replace that to Z in the URL path in your FTP client).
0 means 4GB really which the size of the largest file on FATx file system. Might clean itself up or it might overwrite next time you play a stream.
carpmandanw
Posts: 2
Joined: Thu Jan 16, 2014 6:41 pm

Re: Buffering issue / cachemembuffersize fixed

Post by carpmandanw »

Dan Dar3 wrote:@carpmandanw
Z: is a partition, you can actually access it through FTP if you want (if not listed in the root, try going to say Q and then replace that to Z in the URL path in your FTP client).
0 means 4GB really which the size of the largest file on FATx file system. Might clean itself up or it might overwrite next time you play a stream.
Nice one, thanks for the reply.
Now to find some links that work seem to be a lot not loading today.
largeowl
Posts: 15
Joined: Mon Dec 02, 2013 7:11 am

Re: Buffering issue / cachemembuffersize fixed

Post by largeowl »

Whufclee.myftp.org Server not found HELP i need the adancedsettings.xml
User avatar
mrmajikbus45
Posts: 344
Joined: Mon Nov 18, 2013 12:36 am
Location: Indianapolis, IN, USA
Has thanked: 32 times
Been thanked: 56 times

Re: Buffering issue / cachemembuffersize fixed

Post by mrmajikbus45 »

Check your PM.
A strong man doesn't need to read the future, he makes his own. -Solid Snake
American as Guile!
Get your Chimp on!
User avatar
Xphazer
Posts: 522
Joined: Wed Jul 04, 2012 4:39 am
Location: Montréal
Has thanked: 235 times
Been thanked: 100 times

Re: Buffering issue / cachemembuffersize fixed

Post by Xphazer »

largeowl wrote:Whufclee.myftp.org Server not found HELP i need the adancedsettings.xml
It's available from in the OP, and anyway you should be able to create your own from the OP informations...
User avatar
mrmajikbus45
Posts: 344
Joined: Mon Nov 18, 2013 12:36 am
Location: Indianapolis, IN, USA
Has thanked: 32 times
Been thanked: 56 times

Re: Buffering issue / cachemembuffersize fixed

Post by mrmajikbus45 »

Xphazer, he came from one of my topics. I got him hooked up. No worries.
A strong man doesn't need to read the future, he makes his own. -Solid Snake
American as Guile!
Get your Chimp on!
Post Reply