Trouble installing dashboard

Discussion about Modding the XBOX, including hardware and software hacks.
Post Reply
Posts: 3
Joined: Mon Aug 19, 2019 8:38 pm
Has thanked: 1 time

Trouble installing dashboard

Post by blippid » Mon Aug 19, 2019 8:51 pm


I'm having trouble installing EvoX dashboard on my modded Xbox. The previous hard drive stopped working, and I had no backup. Lesson learned..

The hexen dvds doesn't boot up right. It says Linux under the xbox-logo, but nothing happens after that. Slayers 2.7 boots up fine, and I've tried to format and install the new hard drive I've put in (an old Seagate 40GB IDE drive) but it gives me error 13 witch I understand signals no dash found?

When booted into slayers I can connect to my Xbox through FTP. I'm not allowed to copy or change the files, but I can see the content of the folders. Default.xbe is placed i D: and C: is empty. Is this why I'm having problems booting up?

Slayers tells me that the bios installed are EvoX M8 v16 00 and that all my drives have 0 GB free space. The chip installed is Aladdin.

What is the best way to fix this? I'm very confused.

Posts: 344
Joined: Thu Mar 19, 2015 4:01 am
Has thanked: 51 times
Been thanked: 39 times

Re: Trouble installing dashboard

Post by Coldly-Indifferent » Tue Aug 20, 2019 12:28 am

As you are using a chipped Xbox there should be no trouble with any disc. Not sure why you want an EvoX main dash - XBMC is obviously the main preference here but as an alternative main dash or installed as app dash: UnleashX with its built in File Explorer and other menu options EvoX doesn't have is the recommended second choice.

Even if the HDD is blank/virgin a cold booted install disc should walk you through the formatting and then you can install your dash of choice. I don't know Slayers so I wouldn't use it even though that is specifically meant only for chipped machines. But I would guess everything is OK and that the formatting went OK. All you may need to do now is actually install the dash you want from it main menu.

I've just had a look at the Slayers manual (Google for that, it is easily found). If you used the New Install/Full Rebuild option it should have installed an EvoX dash all as part of the process.

HeXEn should have worked OK but it does take 20 -30 secs to boot. If it doesn't boot after that I'd suspect it was burned on media incompatible with your Xbox's disc drive. The Slayers' disc is probably burned on media that is OK, hence the difference.

Use DVD-R burned using ImgBurn default "Write image file to disc" at the lowest supported speed, usually x4.

Alternatively find an AID v4.53 (Auto Installer Deluxe) download, burn that in the same way and use the chipped Xbox specific menu options. BTW it takes even longer to boot from disc than HeXEn.

Posts: 3
Joined: Mon Aug 19, 2019 8:38 pm
Has thanked: 1 time

Re: Trouble installing dashboard

Post by blippid » Tue Aug 20, 2019 12:40 am

Coldly-Indifferent wrote:
Tue Aug 20, 2019 12:28 am
Thank you so much for your reply! It's difficult to find people with expertise on this, and I appreciate you and this community so much!

Both Hexen and Slayers was burned on the same type of disc and with the same software so that shouldn't be the problem. I tried with hexen 2018 and 2019 and got the same disappointing result: won't boot up!

The things I've tried tonight without results:
install/rebuild upgraded/large HDD with slayers 3 times.
install evox dashbord to both c: and f:
flash bios to evox M8 and find dash in c: f: and g:
installed different dashboards (unleashx, xbmc and avalanchx) in f: and g:

I'm downloading auto installer deluxe v4.53 now. Will try to rebuild the hard drive and install the dashes from there. Thank you for the recommending xbmc. Last time I used this Xbox was in 2008 and evox was the only dash installed, hence I only really know that one.

Is there something I could have overlooked maybe?

Post Reply