Audio CD Ripping Issue

If you need any help with XBMC4XBOX, such as installing or using the software, please post it in here.
Post Reply
Coldly-Indifferent
Posts: 295
Joined: Thu Mar 19, 2015 4:01 am
Has thanked: 40 times
Been thanked: 35 times

Audio CD Ripping Issue

Post by Coldly-Indifferent » Wed Dec 26, 2018 5:21 pm

XBMC v3.5.3 + Xbox-Classic skin, Xecuter v2.6 chipped v1.6 Xbox.

This is a bit weird as it might be some type of copying protection issue.

I was given a factory sealed music CD for Xmas and like I've done with the rest of my (30+) CD collection I wanted to rip it to my Xbox's HDD as that's what is used most for playing music.

To start with ripping an audio CD on PC is a bit of faff anyway so I've often done that on the Xbox using XBMC and then FTPed a copy to PC to tag it exactly as I want and add cover art etc before FTPing it back to the Xbox.That's what I did or tried to do in this case.

The rip to .mp3 appeared to work fine, all 13 tracks done and all played correctly. For whatever reason I decided to rename the tracks (from Track.01.mp3, Track.02.mp3... etc) at this point rather than do it on PC. I used the XBMC File Manager: Folder name = Album name and the tracks each done in exactly the same way: Artist name - Track Name with the same .mp3 extension unchanged.

Here's the problem: with five of the tracks the moment I finished renaming them they stopped being recognised as .mp3 audio cd tracks. They still had the .mp3 extension but renamed they just would not play. I restarted XBMC: same problem, I redid the renaming checking I hadn't made and stupid errors: same problem.

I re-ripped the five tracks. Again all played fine as Track.01.mp3 etc but the moment they were renamed the trouble re-appeared. The other tracks all played perfectly.

Even when I went to my UnleashX dash and tried to play those renamed problem tracks: nothing.

The final weirdness is that when I swapped to the UnleashX File Explorer and did the renaming there the five tracks all renamed fine and played fine. I swapped back to XBMC and.........they worked fine there too. :?

So whatever the trouble is it seems to be a XBMC one in combination with this particular CD. I've had the very occasional music CD track refuse to rip to .mp3 with XBMC. What I've done in those cases is rip the offending track to .wav using the Xbox dash. That always works but this is a different problem in that simply changing the name of a .mp3 stops it being recognised as an audio file.

Any explanation appreciated.

Post Reply