keymapping woes

If you need any help with XBMC4XBOX, such as installing or using the software, please post it in here.
Post Reply
webodan
Posts: 5
Joined: Tue Nov 28, 2017 8:41 pm

keymapping woes

Post by webodan » Mon Dec 04, 2017 3:58 am

Hello,

I've just soldered in a usb socket on my XBOX and quite surprisingly, this little USB remote (it's actually just an HID keyboard in a small pcb fit to look like a remote) that I bought over ebay happens to work, but only its arrow keys will work properly. Oddly, when I move the keys to the left (on the options pane on the left hand side of the XBMC4xbox interface that has view, sort, grouping etc) within that section the enter key works, but when I try to select any option on the right it does not. I've found in xbmc.log that the key id is 61453 , but when I've tried to map it as <key id='61453'>Select</key> in keyboard.xml in all sections of this file (having checked that in gamepad.xml , <A>Select</A> is set up), it doesn't work. the log keeps saying

Code: Select all

01:28:49 M: 42545152   DEBUG: CApplication::OnKey: 61453 pressed, trying keyboard action 61706
Am I doing something wrong? could i please get some input?

Thanks in advance.

User avatar
Dan Dar3
Posts: 1106
Joined: Sun Jul 08, 2012 4:09 pm
Has thanked: 216 times
Been thanked: 230 times
Contact:

Re: keymapping woes

Post by Dan Dar3 » Sat Dec 09, 2017 10:37 am

If I read the Wiki page correctly I think you can add your own keymap XML file(s) in Q:\UserData\keymaps\*.xml where you can selectively add / override keys instead of changing the system configuration files (Q:\system\keymaps\*.xml).
https://www.xbmc4xbox.org.uk/wiki/Keyboard.xml

Anyway now to your problem, it appears the log message is being printed out from Application:OnKey(). Because of this check below it switches to "edit mode" and it does some odd stuff with the key code for larger number (usually Unicode char codes, > 127) probably to treat it as a typed character, as opposed to the configured action which is right after that in the code flow (see link below).

Code: Select all

        if (control->GetControlType() == CGUIControl::GUICONTROL_EDIT ||
            (control->IsContainer() && g_Keyboard.GetShift()))
          useKeyboard = true;
https://redmine.exotica.org.uk/projects ... .cpp#L2376

Can you confirm what skin are you using, a screen you've tested with and what's on the right side, maybe a screenshot somewhere? That might help to figure out the condition above and how to go past that to trigger the expected action.

webodan
Posts: 5
Joined: Tue Nov 28, 2017 8:41 pm

Re: keymapping woes

Post by webodan » Sun Dec 10, 2017 3:57 pm

Sorry for that horrible explanation that I gave before and thanks for your help, Dan Dar3. I was using the Xbox-Classic skin but have since switched to Project Mayhem III, and it does the same error. I've tested further, and the enter key works fine all the menus except for the Music, Videos and Applications menus (with "the right side" i referred to the section in the GUI where i can select my video / audio / application content sources) so it's essentially useless for actually "using" the system, since I can only configure things in the Settings menu and that's it.

User avatar
Dan Dar3
Posts: 1106
Joined: Sun Jul 08, 2012 4:09 pm
Has thanked: 216 times
Been thanked: 230 times
Contact:

Re: keymapping woes

Post by Dan Dar3 » Sun Dec 10, 2017 9:42 pm

No, you did pretty good investigating this.

Not sure if you're running on the latest 3.5.3 version (can check in System Info or top of Q:\xmbc.log) or whether you tried with better luck the default Confluence Lite skin?

I could re-build v3.5.3 for you without the piece of code that I think might be causing this, see if it works any better? or at least to provide more logging.

Post Reply