Samba client keeps asking for password

If you need any help with XBMC4XBOX, such as installing or using the software, please post it in here.
Post Reply
webodan
Posts: 5
Joined: Tue Nov 28, 2017 8:41 pm

Samba client keeps asking for password

Post by webodan » Tue Nov 28, 2017 8:48 pm

Hello,

I'm setting a NAS with a raspberry pi and I can't get XBMC4Xbox to join my share. I've set 2 shares for the same drive, one read only with anonymous login enabled and one with write protection and a samba user set up on it. I just can't get it to work either way and I don't understand why. On my Windows and Linux boxes I can browse it perfectly fine with both shares but not on XBMC4Xbox. It keeps asking for a username and password on both shares and when I provide them (either guest or nobody on the read only share or pi on the password-protected share) it seems to ignore them, doesn't give an error or anything. Can I please get some help? :?

Here is my smb.conf file on the raspberry pi

Code: Select all

pi@raspberrypi:~ $ cat /etc/samba/smb.conf

[global] 

	log level = 1 
	max log size = 1000
	workgroup = WORKGROUP

[MaxtorNet]

	comment = maxtor
	path = /mnt/test
	browsable = yes
	writeable = yes
	guest ok = no
	valid users = pi
	create mask = 0660
	directory mask = 0771
	read only = no

[MaxtorNetRO]

        comment = maxtor read only
        path = /mnt/test
        browsable = yes
        guest ok = yes
	read only = yes
	read list = guest, nobody
        create mask = 0660
        directory mask = 0771
On the XBOX I'm running XBMC4Xbox 3.5.1-r32990 (from may 31 2015).

Thanks in advance.

edit: never mind, i switched to DLNA streaming since it works great on my xbox as a receiver.

Post Reply