Way too many problems and bugs

Discussion about Modding the XBOX, including hardware and software hacks.
Post Reply
tx3000
Posts: 23
Joined: Sat Apr 17, 2021 8:26 am

Way too many problems and bugs

Post by tx3000 »

Ok so I soft modded my xbox and installed XBMC4GAMERS to E so it's the main dash.
Put a bunch of xbox games, and 5 emulators and their roms and got that all straight.

FIRST PROBLEM:
When booting the XBOX, in order to get to any icons in XBMC4GAMERS menu I have to press the B button on the controller.
Furthermore things like DVD2XBOX and the artwork installer would no longer launch when I clicked on them in the menu of XBMC4GAMERS..I had to go to file explorer and manually click the default.xbe in order to launch it

I then wanted EMUSTATION so I downloaded it via the urldownloader to F
Upon rebooting the xbox EMUSTATION decided it was going to be the main dashboard despite it being on F and XBMC4GAMERS was still on E.

Despite having roms and emulators, the only thing emustation detected was all the xbox games it didn't detect a singhle emulator or any of the roms even after scanning, and when i tried to manually scan it, it said no roms were found which is bullshit because I was just playing them through the emulators before i downloaded emustation.

In short Emustation is total garbage. Decides tot take over as the main dashboard, and doesn't even recognize emulators.

So I deleted emustation and also had to remove XBMC4GAMERS all of this needs to be fixed.
User avatar
professor_jonny
Posts: 1268
Joined: Thu Jul 05, 2012 5:41 am
Location: New Zealand
Has thanked: 66 times
Been thanked: 190 times

Re: Way too many problems and bugs

Post by professor_jonny »

tx3000 wrote: Sat May 22, 2021 2:20 am
I then wanted EMUSTATION so I downloaded it via the urldownloader to F
Upon rebooting the xbox EMUSTATION decided it was going to be the main dashboard despite it being on F and XBMC4GAMERS was still on E.
It sounds like it could be possibly booting of an alternative dash boot path from the bios you hve installed, but with out you providing more info I can only make asumption's
tx3000 wrote: Sat May 22, 2021 2:20 am
Despite having roms and emulators, the only thing emustation detected was all the xbox games it didn't detect a singhle emulator or any of the roms even after scanning, and when i tried to manually scan it, it said no roms were found which is bullshit because I was just playing them through the emulators before i downloaded emustation.
I believe the roms etc need to be put inside the folder structure of emustation, (I'm a bit rusty on this it is a long time since i played with this)
eg:

/F/XBMC-Emustation_file/.emustation/ looks like this:

/emulators/snes/

/media/snes/boxart

/media/snes/boxart3d

/media/snes/logo

/media/snes/mix

/media/snes/screenshots

/media/snes/videos

/roms/snes
tx3000
Posts: 23
Joined: Sat Apr 17, 2021 8:26 am

Re: Way too many problems and bugs

Post by tx3000 »

@professor_jonny
Your reply is completely irrelevant and unrelated to anything I posted. If XBMC4GAMERS is the dash on G:/, then downloading Emustation to the F:/ Drive and rebooting the xbox, should not ever cause it to take over as the main dashboard. Yes you read that correctly, before touching a single setting on anything, it took over as the main dash from F:/.

The second issue is that you seemed to totally ignore, is how I point blank said that I had the Atari 2600, Gameboy Advance, Playstation, and Super Nintendo Emulators, already on my xbox and all 4 had the base artwork and everything worked 100% BEFORE emustation was even downloaded.

Once I downloaded EMUSTATION to F:/ (As I said above it took over as the main dash which then lead to the prompts of the generic settings (i.E. the calibration) afterwards were all set up. I did a scan for the emulators and the automatic scan for the ROMS when that prompt came up on the screen. After the scan was done the only thing it detected was the xbox games...
no emulators and it said there were no roms. Which is crap because all 4 emulators I mentioned above with all the roms WERE ON THE XBOX and emustation said it couldn't find both the emulators themselves and the roms.

I then moved the emulators and the roms into EMUSTATION ITSELF the emulators went in the emulators folder. I ran the scan a second time (including the automatic detection of the roms) once again EMUSTATION showed no emulators and roms detected.

I then moved the roms from the emulator directory into the roms directory in EMUSTATION and ran the scan for a 3rd time, once again EMUSTATION showed no emulators and no roms were detected.

I then moved the emulators themselves into the folder name of emustation so the atari 2600 emulator itself was now in the emustation (atari2600) folder the gameboy advance was now in the GBA, the playstation was now in psx, and the Super Nintentdo was now in SNES.

Once again I ran the scan...once again EMUSTATION showed no emulators and no roms were detected.

I just deleted this PoS garbage software. After deleting emustation an additional problem showed up.
Somehow emustation on it's own decided to magically create 2 directories that showed up under the games on F:/ there were now screenshot directories for both the gameboy advance and playstation in F:/games. it even had icons showing as no artwork..Took me 20 minutes to figure out how to get rid of them.

EMUSTATION takes over a sdashboard on a drive it's not possible to take over on (Especially when a dashboard is already on G as the main, and then it doesn't detect anything, and on top of that creates mystery directories..EMUSTATION is a broken mess and needs to be fixed.

You cannot even make an excuse for any of this. The Artwork creator video rocky5 has on youtube is another mess that took me over 14 hours to finally fix and able to actually create any artwork. I already posted on this forum for people to go flag that video to get it removed.

My point is, everything Rocky is involved in breaks and incoherent and thus screws it up beyond comprehension. Rocky SHOULD NOT be allowed to be posting anything as a HOW-TO. he has absolutely no clue what he doing with that aspect of it.

I teamed up with someone who is in the process of making a real video tutorial on how to create the artwork for XBMC4GAMERS. When that is done, compare that one to Rocky5's and you will see just how bad he is and what he has done.
User avatar
professor_jonny
Posts: 1268
Joined: Thu Jul 05, 2012 5:41 am
Location: New Zealand
Has thanked: 66 times
Been thanked: 190 times

Re: Way too many problems and bugs

Post by professor_jonny »

tx3000 wrote:@professor_jonny

I teamed up with someone who is in the process of making a real video tutorial on how to create the artwork for XBMC4GAMERS. When that is done, compare that one to Rocky5's and you will see just how bad he is and what he has done.

You omit in your initial post that you had moved anything into the correct folder structure as required by emustation I did not ignore your post I gave you a valid reason for your roms not working, lacking better info.

How about you start over and give us the whole story in a detailed step by step of what you did this time?

Yes it is possible emustation could take over as dash if your bios points to it or or you have a shortcut pointing to it, this is not a problem of the installer.
The bios will boot the first instance of a valid boot dash, it selects this based on the order programmed in bios.
It is s reasonable cause for our of your problem it is not irrelevant, lacking better info this is the only conclusion I could come to.


You need to tone down a bit in your reply it seems you have a personal vendetta against rocky5 which I believe is not warranted, if you and your mate think you can do better then go for it.

I even help if you wish and pick out all the faults in your video's and post on the forum as help.

Sent from my SM-G970F using Tapatalk
Last edited by professor_jonny on Fri May 28, 2021 6:08 am, edited 1 time in total.
tx3000
Posts: 23
Joined: Sat Apr 17, 2021 8:26 am

Re: Way too many problems and bugs

Post by tx3000 »

@professor_jonny
I explained exactly what happened, and I didn't omit anything.
I'm now just going to place you on ignore for being as ignorant as you are, and purposely trying to antagonize me into an argument.
Post Reply