Directory not found??

If you need any help with XBMC4XBOX, such as installing or using the software, please post it in here.
Post Reply
therobman
Posts: 5
Joined: Wed Jan 03, 2018 7:14 am

Directory not found??

Post by therobman » Thu Jan 18, 2018 5:43 am

I had a question and could not find an answer on a lot of games I’m trying to ftp to the system. Ive tried multiple ftp clients cxboxtool, winscp, filezilla with the same issues it comes back directory not found? I attached a few images of 2 different games using different ftp programs. I can’t seem to figure out what the issue is. I transferred multiple games no problem and now this error is popping up frequently


Image

Image

Coldly-Indifferent
Posts: 338
Joined: Thu Mar 19, 2015 4:01 am
Has thanked: 49 times
Been thanked: 38 times

Re: Directory not found??

Post by Coldly-Indifferent » Thu Jan 18, 2018 2:36 pm

What about the F:\ drive, any chance it is getting full?

If it is a large HDD being used were the extended partitions formatted correctly?

I'm no expert on FTP issues at all but in my limited experience I've seen the directory not found message seems to be used as an indication of some unspecified trouble with the transfer rather than just what it appears to mean. The problem being across multiple FTP clients which have been used successfully before could suggest that there has been some change to your system or settings.

Could it be a new firewall or anti-virus update issue which is blocking the transfer of what it now sees as potentially risky files? You'd expect a message to that affect though.

Have you tried copying the game to a temporary (TMP) folder on the root of the F:\ drive rather than direct to F:\Games folder? I'm thinking it might be a folder level or incompatible name/character issue. If it is happening repeatedly at a particular point ie. with a specific file of a particular game have you tried transferring that separately?

User avatar
Dan Dar3
Posts: 1166
Joined: Sun Jul 08, 2012 4:09 pm
Has thanked: 255 times
Been thanked: 251 times
Contact:

Re: Directory not found??

Post by Dan Dar3 » Thu Jan 18, 2018 2:44 pm

Xbox's file system (FATX) file system has a number of limitations, not sure what is causing yours exactly...
http://www.free60.org/wiki/FATX#Limitations

Can you enable screen logging and try to create that one folder manually, and give us the response from the server? Not the entire copy, simply try to create the path that shows on screeen (/F/Games/Need For Speed Underground 2/B3/).
  • Free space on F?
  • Was it formatted correctly? (not much an expert on how to correctly formatting large Xbox partitions).
  • How many subdirectories do you have in the F:\Games folder?
  • Does the same transfer correctly on another partition, say /E/Games/Need For Speed Underground 2/B3/?
    that would confirm a problem with the parent folder or the partition itself.

therobman
Posts: 5
Joined: Wed Jan 03, 2018 7:14 am

Re: Directory not found??

Post by therobman » Thu Jan 18, 2018 5:31 pm

It is a 1tb drive and about 6xx free on F, I picked it up already softmodded so i am not sure how it was formated. From the computer stand point nothing changed. I did however try to ftp the same game that on my F partiton gave me the error immediately to the E drive and it started to transfer without any issues. Someone else had mentioned to me before maybe the drive was not formated correctly and to try XBpartition and try splitting the partition into F and G. Did try creating the subfolder B3 for NFS manually in file explorer on the system and with ftp and it would not create

therobman
Posts: 5
Joined: Wed Jan 03, 2018 7:14 am

Re: Directory not found??

Post by therobman » Thu Jan 18, 2018 5:33 pm

i have about 110 games on the drive no other media at the moment space is definitely not the issue

Coldly-Indifferent
Posts: 338
Joined: Thu Mar 19, 2015 4:01 am
Has thanked: 49 times
Been thanked: 38 times

Re: Directory not found??

Post by Coldly-Indifferent » Fri Jan 19, 2018 1:45 am

I think if you do a few searches here about using and partitioning 1TB HDD you'll find information that once you go over 512GB with the F:\ drive using all the space you can get corruption if it was only partitioned with 32KB clusters.

A 1TB drive with a single F:\ drive rather than split into F and G each of <512GB (the max size for using 32KB clusters) should be partitioned with 64KB clusters. So if that was not done then you may well have the explanation as to why the folders have started going missing.

Whether it is safe to delete content on F:\ to get it well below 512GB and then create a G:\drive for the >512GB space remaining and use 64KB clusters just for that I don't know. If Rocky5 is around he's the guy to ask about that sort of thing and

The usual practice with a 1TB HDD is to split F and G equally, as described both, with 64KB cluster size. That is actually mandatory for a 2TB HDD.

Whatever you decide to do you'll need either XBPartitioner v1.3 or Chimp261812 to confirm what cluster size is being used for your F:\ drive.

Post Reply