No (Ass) subs showing on mkv video on Xbmc 3.5.3-3.5 RC

If you need any help with XBMC4XBOX, such as installing or using the software, please post it in here.
Post Reply
Kinstinct2
Posts: 27
Joined: Thu Dec 20, 2012 6:16 pm
Has thanked: 2 times
Been thanked: 2 times

No (Ass) subs showing on mkv video on Xbmc 3.5.3-3.5 RC

Post by Kinstinct2 » Sat Mar 05, 2016 1:54 am

This is just a initial test I will post again with debug/log. Last XBMC I was using was 3.5.4 beta will test rc, final, 3.5.1, and last nightly.
Video plays fine using dvdplayer but I do have full codecs chosen for dvdplayer.

Xbmc 3.5 beta4 working: http://pastebin.com/dihHJjsz debug http://pastebin.com/ZYMb6V2K

Xbmc 3.5 rc not working debug http://pastebin.com/F1ErPL4r

Xbmc 3.5 not working http://pastebin.com/vRxndCMC

Xbmc 3.5.1 not working http://pastebin.com/NRUe0Jks

Xbmc 33017 nightly not working http://pastebin.com/7n1uSqd8 debug http://pastebin.com/N7Hf6ryH

Only 3.5 beta 4 seems to work with ass subtitles from my test with anime video. If others could test in case I messed up somewhere would be appreciated

Forgot to put system in debug mode will repost logs as debug here are 3 of them done for now

User avatar
Dan Dar3
Posts: 1166
Joined: Sun Jul 08, 2012 4:09 pm
Has thanked: 254 times
Been thanked: 251 times
Contact:

Re: No (Ass) subs showing on mkv video on Xbmc 3.5.3-3.5 RC

Post by Dan Dar3 » Fri Mar 11, 2016 8:20 pm

Comparing the two DEBUG logs (first and last) I'd say this is where the problem shows (last 2 lines):

XBMC4Xbox 3.5 beta4 r32788 (working)

Code: Select all

01:45:41 M: 23457792  NOTICE: Opening Subtitle stream: 2 source: 256
01:45:41 M: 23457792  NOTICE: running thread: CDVDPlayerAudio::Process()
01:45:41 M: 23437312   DEBUG: FactoryCodec - Overlay: SSA Subtitle Decoder - Opening
01:45:41 M: 23437312   ERROR: Unable to open dll Q:\system\players\dvdplayer\libass.dll
01:45:41 M: 23437312   ERROR: CDVDSubtitlesLibass: Failed to load libass library
01:45:41 M: 23437312   DEBUG: FactoryCodec - Overlay: SSA Subtitle Decoder - Failed
01:45:41 M: 23437312   DEBUG: FactoryCodec - Overlay: Text Subtitle Decoder - Opening
01:45:41 M: 23437312   DEBUG: FactoryCodec - Overlay: Text Subtitle Decoder - Opened
XBMC4Xbox r33017 nightly (not working)

Code: Select all

01:37:30 M: 22806528  NOTICE: Opening Subtitle stream: 2 source: 256
01:37:30 M: 22806528  NOTICE: running thread: CDVDPlayerAudio::Process()
01:37:30 M: 22806528   DEBUG: FactoryCodec - Overlay: SSA Subtitle Decoder - Opening
01:37:30 M: 22806528   ERROR: Unable to open dll Q:\system\players\dvdplayer\libass.dll
01:37:30 M: 22806528   ERROR: CDVDSubtitlesLibass: Failed to load libass library
01:37:30 M: 22806528   DEBUG: FactoryCodec - Overlay: SSA Subtitle Decoder - Failed
01:37:30 M: 22806528   ERROR: CDVDPlayerSubtitle::OpenStream - Unable to init overlay codec
01:37:30 M: 22806528 WARNING: CDVDPlayer::OpenSubtitleStream - Unsupported stream 2. Stream disabled.
3.5 RC1 (r32881) shows the same problem, even if not a debug log.

XBMC4Xbox 3.5 RC1 r32881 (not working)

Code: Select all

23:53:38 M: 22671360   DEBUG: FactoryCodec - Overlay: SSA Subtitle Decoder - Opening
23:53:38 M: 22671360   ERROR: Unable to open dll Q:\system\players\dvdplayer\libass.dll
23:53:38 M: 22671360   ERROR: CDVDSubtitlesLibass: Failed to load libass library
23:53:38 M: 22671360   DEBUG: FactoryCodec - Overlay: SSA Subtitle Decoder - Failed
23:53:38 M: 22675456   ERROR: CDVDPlayerSubtitle::OpenStream - Unable to init overlay codec
23:53:38 M: 22675456 WARNING: CDVDPlayer::OpenSubtitleStream - Unsupported stream 2. Stream disabled.
Now to the "exciting" part, going from revision r32788 backwards to 32881 (page 10 to 6 as of now) and identify any change that might have to do or affecting subtitles...
http://redmine.exotica.org.uk/projects/ ... ns?page=10

User avatar
BuZz
Site Admin
Posts: 1889
Joined: Wed Jul 04, 2012 12:50 am
Location: UK
Has thanked: 62 times
Been thanked: 422 times
Contact:

Re: No (Ass) subs showing on mkv video on Xbmc 3.5.3-3.5 RC

Post by BuZz » Fri Mar 11, 2016 10:21 pm

This may have been because I was planning to get the libass library working, and never did - and somewhere along the way broke the falling back. There is at least one ticket open you can add information to http://redmine.exotica.org.uk/issues/205

Post Reply