Scraper Issues

If you need any help with XBMC4XBOX, such as installing or using the software, please post it in here.
roboamiga
Posts: 8
Joined: Sat Sep 14, 2013 10:59 pm
Has thanked: 3 times
Been thanked: 1 time

Re: Scraper Issues

Post by roboamiga » Sun Sep 29, 2013 10:12 pm

Thanks for the tip toocko. Have used .tbn files before when adding icons for emulators but never thought to use them for films.
True it would be better to have the full scraped movie info, but at least having artwork stops things looking quite so ugly when we have a movie night with friends.

User avatar
Maza
Posts: 85
Joined: Wed Jul 04, 2012 5:06 pm
Location: Portugal
Has thanked: 3 times
Been thanked: 5 times

Re: Scraper Issues

Post by Maza » Mon Sep 30, 2013 5:16 am

I took some time to look into the response buzz gave see http://redmine.exotica.org.uk/issues/254, but I still haven't figured this out yet so it will take a little more time.
Xbox 1.4, softmod, 250 GB HDD, Monster Gamelink 400 X Component Video & Monster LightWave 100 X, silent fan mod, Confluence Lite 720p

User avatar
BuZz
Site Admin
Posts: 1889
Joined: Wed Jul 04, 2012 12:50 am
Location: UK
Has thanked: 62 times
Been thanked: 422 times
Contact:

Re: Scraper Issues

Post by BuZz » Mon Sep 30, 2013 11:34 am

i will probably get around to sorting it, I just have other things going on right now. and xbmc4xbox doesn't pay my mortgage :)

User avatar
Dan Dar3
Posts: 1166
Joined: Sun Jul 08, 2012 4:09 pm
Has thanked: 255 times
Been thanked: 251 times
Contact:

Re: Scraper Issues

Post by Dan Dar3 » Mon Sep 30, 2013 2:57 pm

Sorry I didn't have time to look at it either, I'm quite swamped myself (looking to change jobs, interviews, work), mad...

User avatar
sixties keith
Posts: 526
Joined: Wed Aug 01, 2012 9:30 am
Has thanked: 24 times
Been thanked: 30 times

Re: Scraper Issues

Post by sixties keith » Thu Oct 10, 2013 6:52 pm

im still having issues with my xbox . has a fix been released for this issue
Image

120gb hdd, vinyl magma skin, front lights, side strip lights, clear jewel mod with lights, ir dongle mod, hdd indicator. X3 with LCD many mods inc custom x3 jewel.

foresto
Posts: 8
Joined: Tue Jun 18, 2013 4:44 am
Been thanked: 4 times

Re: Scraper Issues

Post by foresto » Thu Oct 10, 2013 7:01 pm

In addition to the themoviedb.com api problem, I'm no longer getting movie images when I use the imdb.com scraper. Anyone else?

foresto
Posts: 8
Joined: Tue Jun 18, 2013 4:44 am
Been thanked: 4 times

Re: Scraper Issues

Post by foresto » Fri Oct 11, 2013 9:39 am

Confirmed: Thumbnail retrieval is broken in the imdb and movieposterdb scrapers.

Bug report here: http://redmine.exotica.org.uk/issues/258

I fixed the problems, too. See the bug report for a patch and fixed scraper files.

roboamiga
Posts: 8
Joined: Sat Sep 14, 2013 10:59 pm
Has thanked: 3 times
Been thanked: 1 time

Re: Scraper Issues

Post by roboamiga » Fri Oct 11, 2013 8:57 pm

foresto wrote:Confirmed: Thumbnail retrieval is broken in the imdb and movieposterdb scrapers.

Bug report here: http://redmine.exotica.org.uk/issues/258

I fixed the problems, too. See the bug report for a patch and fixed scraper files.
Excellent! If this gets imdb scraping properly again then it will work for me as a replacement for moviedb scraping for now :)
Going to try your patch shortly and will report back on how it works out.

foresto
Posts: 8
Joined: Tue Jun 18, 2013 4:44 am
Been thanked: 4 times

Re: Scraper Issues

Post by foresto » Fri Oct 11, 2013 10:34 pm

Cool. I was working on this late into the night. Knowing that it helps others will make me feel better about all the time I spent on it.

roboamiga
Posts: 8
Joined: Sat Sep 14, 2013 10:59 pm
Has thanked: 3 times
Been thanked: 1 time

Re: Scraper Issues

Post by roboamiga » Sat Oct 12, 2013 12:04 am

Well I have just tried your fix foresto and can confirm IMDB is scraping sucessfully as I type :D
Thanks again, Its great to have this function working once more as we have a couple of xboxes in our front room and around the house all used as networked media centres as well as for emulators etc.
Im suprised nobody else has commented on this yet but im sure there will be lots of grateful people!

Xzawier1777
Posts: 6
Joined: Tue Sep 24, 2013 10:32 pm
Has thanked: 1 time
Been thanked: 1 time

Re: Scraper Issues

Post by Xzawier1777 » Sat Oct 12, 2013 8:35 am

OK this is working just fine here too !!
Even for TV Shows !

Thank you a lot, you saved the old Lady again !!!

User avatar
AwesomeNurd
Posts: 332
Joined: Mon Jul 30, 2012 3:01 pm
Location: London, United Kingdom
Has thanked: 22 times
Been thanked: 10 times

Re: Scraper Issues

Post by AwesomeNurd » Sat Oct 12, 2013 2:24 pm

It's working for the movies posters but it doesn't fix the fanarts I think :) Hopefully this will be fixed with the next XBMC version. (for music scrapers as well)

bsell1
Posts: 45
Joined: Sat Sep 22, 2012 11:11 pm
Has thanked: 2 times

Re: Scraper Issues

Post by bsell1 » Sat Oct 12, 2013 5:31 pm

I know this is probably stupid, but how exactly do I apply this patch?

foresto
Posts: 8
Joined: Tue Jun 18, 2013 4:44 am
Been thanked: 4 times

Re: Scraper Issues

Post by foresto » Mon Oct 14, 2013 1:15 am

AwesomeNurd wrote:It's working for the movies posters but it doesn't fix the fanarts I think :) Hopefully this will be fixed with the next XBMC version. (for music scrapers as well)
As far as I know, imdb doesn't offer any fan art.

User avatar
AwesomeNurd
Posts: 332
Joined: Mon Jul 30, 2012 3:01 pm
Location: London, United Kingdom
Has thanked: 22 times
Been thanked: 10 times

Re: Scraper Issues

Post by AwesomeNurd » Mon Oct 14, 2013 2:15 pm

Yes you are right, I used themoviedb in the past to get the fanart images :)

The TVDB is working without any issue to get the TV Shows poster/banners and fanart :)

foresto
Posts: 8
Joined: Tue Jun 18, 2013 4:44 am
Been thanked: 4 times

Re: Scraper Issues

Post by foresto » Mon Oct 14, 2013 7:39 pm

bsell1 wrote:I know this is probably stupid, but how exactly do I apply this patch?
If you're not working with the source code, it will be easier for you to download the three already-patched files from my bug report and use them to replace the corresponding files in your xbmc installation. I did this via ftp.

bsell1
Posts: 45
Joined: Sat Sep 22, 2012 11:11 pm
Has thanked: 2 times

Re: Scraper Issues

Post by bsell1 » Mon Oct 14, 2013 8:06 pm

foresto wrote:
bsell1 wrote:I know this is probably stupid, but how exactly do I apply this patch?
If you're not working with the source code, it will be easier for you to download the three already-patched files from my bug report and use them to replace the corresponding files in your xbmc installation. I did this via ftp.

Ok, so just take the 3 xml files and put them in the appropriate places, and just ignore the patch file?

foresto
Posts: 8
Joined: Tue Jun 18, 2013 4:44 am
Been thanked: 4 times

Re: Scraper Issues

Post by foresto » Mon Oct 14, 2013 8:15 pm

Exactly.

User avatar
BuZz
Site Admin
Posts: 1889
Joined: Wed Jul 04, 2012 12:50 am
Location: UK
Has thanked: 62 times
Been thanked: 422 times
Contact:

Re: Scraper Issues

Post by BuZz » Mon Oct 14, 2013 9:18 pm

Thanks for the patches. I hope to find some time in the next week to not only look at and apply them but to fix the tmdb scraper up.

User avatar
sixties keith
Posts: 526
Joined: Wed Aug 01, 2012 9:30 am
Has thanked: 24 times
Been thanked: 30 times

Re: Scraper Issues

Post by sixties keith » Tue Oct 15, 2013 10:34 am

cheers for the patch mate. imdb scraping all my film covers again. awesome work
Image

120gb hdd, vinyl magma skin, front lights, side strip lights, clear jewel mod with lights, ir dongle mod, hdd indicator. X3 with LCD many mods inc custom x3 jewel.

Post Reply