Page 1 of 1

XBMC hangs at splash screen

Posted: Sat Sep 07, 2019 6:23 am
by vacatedboat
I have version 3.5.3 xbmc4xbox istalled to f drive but it hangs at splash screen.
Searching i trued creating a advancesettings.xml and turn powersave to false but no change.
I trued deleting the whole folder and reinstall. Also tried to ftp and get q/xbmx.old.log
Not sure what to try next. Its a 1.3 modchip box. Xbmc is not the default dashboard either. Any help would be appreciated. Thanks
Here is a log file.

13:27:05 M: 56078336 NOTICE: -----------------------------------------------------------------------
13:27:05 M: 56057856 NOTICE: Starting XBMC4Xbox 3.5.3-r33027 (SVN:33027, compiler 1310). Built on Feb 27 2016
13:27:05 M: 56057856 NOTICE: special://xbmc/ is mapped to: Q:\
13:27:05 M: 56057856 NOTICE: special://masterprofile/ is mapped to: Q:\UserData
13:27:05 M: 56057856 NOTICE: special://home/ is mapped to: Q:\
13:27:05 M: 56057856 NOTICE: special://temp/ is mapped to: Z:\
13:27:05 M: 56057856 NOTICE: The executable running is: F:\Apps\XBMC\default.xbe
13:27:05 M: 56057856 NOTICE: Log File is located: Q:\xbmc.log
13:27:05 M: 56057856 NOTICE: -----------------------------------------------------------------------
13:27:05 M: 56057856 NOTICE: Unmapped drive T
13:27:05 M: 56057856 NOTICE: Mapping drive T to Harddisk0\Partition6\Apps\XBMC\UserData\
13:27:05 M: 56057856 NOTICE: Setup DirectX
13:27:05 M: 56033280 NOTICE: Mapping drive C to Harddisk0\Partition2
13:27:05 M: 56033280 NOTICE: Mapping drive E to Harddisk0\Partition1
13:27:05 M: 56033280 NOTICE: Unmapped drive D
13:27:05 M: 56033280 NOTICE: Mapping drive D to Cdrom0
13:27:05 M: 56033280 NOTICE: map extended drive F:
13:27:05 M: 56033280 NOTICE: Mapping drive F to Harddisk0\Partition6
13:27:05 M: 56033280 NOTICE: Mapping drive X to Harddisk0\Partition3
13:27:05 M: 56029184 NOTICE: Mapping drive Y to Harddisk0\Partition4
13:27:05 M: 56029184 NOTICE: Unmapped drive Z
13:27:05 M: 56029184 NOTICE: Mapping drive Z to Harddisk0\Partition5
13:27:05 M: 56029184 NOTICE: load settings...
13:27:05 M: 56029184 NOTICE: Mapping drive P to Harddisk0\Partition6\Apps\XBMC\UserData\
13:27:05 M: 56029184 NOTICE: special://profile/ is mapped to: special://masterprofile/
13:27:05 M: 56029184 NOTICE: loading special://masterprofile/guisettings.xml
13:27:05 M: 55889920 NOTICE: Getting hardware information now...
13:27:05 M: 55889920 NOTICE: Checking resolution 10
13:27:05 M: 55889920 NOTICE: Setting autoresolution mode 4
13:27:05 M: 55889920 NOTICE: Loading player core factory settings from special://xbmc/system/playercorefactory.xml.
13:27:05 M: 55889920 NOTICE: Loaded playercorefactory configuration
13:27:05 M: 55869440 NOTICE: Loading player core factory settings from special://masterprofile/playercorefactory.xml.
13:27:05 M: 55869440 NOTICE: special://masterprofile/playercorefactory.xml does not exist. Skipping.
13:27:05 M: 55869440 NOTICE: No advancedsettings.xml to load (special://masterprofile/advancedsettings.xml)
13:27:05 M: 55869440 NOTICE: Default Video Player: dvdplayer
13:27:05 M: 55869440 NOTICE: Default Audio Player: paplayer
13:27:05 M: 55869440 NOTICE: Per AV pack settings are off
13:27:05 M: 55984128 NOTICE: special://masterprofile/sources.xml
13:27:05 M: 49512448 NOTICE: Network: Using DHCP IP settings
13:27:05 M: 49197056 NOTICE: Using idle thread with HLT (power saving)
13:27:05 M: 49184768 NOTICE: Checking the Date!
13:27:05 M: 49184768 NOTICE: start dvd mediatype detection
13:27:05 M: 49119232 NOTICE: initializing playlistplayer
13:27:05 M: 49119232 NOTICE: DONE initializing playlistplayer

I tried doing it as attachment but it kept saying invalid fule extension

Re: XBMC hangs at splash screen

Posted: Sat Sep 07, 2019 3:26 pm
by Coldly-Indifferent
My suggestion would be just to try a new source for the v3.5.3 download. If you're reinstalling a corrupted download then it would explain why the problem repeats.

Install the new download of XBMC in a single level folder, preferably to F:\Apps. Then it will appear as an application in your dash's menu (UnleashX?).

As long as a XBMC installation has a default.xbe it should launch from anywhere. You can test that using UnleashX's File Explorer or other file manager. Just click on the default.xbe inside the XBMC folder and if it does not launch it then the problem is with the XBMC files you're using.

If you FTPed the thing into place that could be the cause of the problem - FTPing to Xbox is rarely trouble free and all it takes is one file that "fails to transfer" you did not notice and that could be it.

Re: XBMC hangs at splash screen

Posted: Sat Sep 07, 2019 9:06 pm
by vacatedboat
Thanks. Yes i used the version on hexen 2018 disc. As i previously installed it on another xbox that is a tsop. It launched no problems. I will try a different version. I have used file explorer to launch as well. Maybe rockys5 softmod dic tools.

Re: XBMC hangs at splash screen

Posted: Sun Sep 08, 2019 1:43 am
by Coldly-Indifferent
I think Rocky 5's XSMT contains XBMC and there is also his XBMC4Kids available too.

Did you try to install XBMC from the HeXEn disc using HeXEn itself to install it? If so that might be the cause of the problem. It is contained, for whatever reason in the folder: "Appz". Why that would make a difference I'm not sure but maybe if you used the disc tools to install it under an UnleashX dash the config.xml is set up for it to be in a specific folder/location. It should still work if you launch it direct from its own default.xbe though.

What you can try instead is simply insert the HeXEn disc (assuming auto-launch is off) and use the UnleashX File Explorer to copy the XBMC folder, in Appz, from the disc into F:\Apps or wherever you want it. If it doesn't work from there then the XBMC files or the disc itself is likely messed up in some way.

Re: XBMC hangs at splash screen

Posted: Sun Sep 08, 2019 2:14 am
by vacatedboat
Might be making progress. The dashboard was quite old. So I used hexen to update dashboard to unleash X and remove any old at e/dash clean up. Then i tried loaded xbmc via its folder xbe and it went to black screen not even a splash this time.. My plan is now to use hexen to reinsrall xbmc and overwrite the current folder. I think it might then work.
My thoughts are there was a conflict with the old dash and xbmc years ago being the default dash. This I hope cleaned it up for me. Will try tonight

Re: XBMC hangs at splash screen

Posted: Sun Sep 08, 2019 4:34 pm
by Coldly-Indifferent
It should not have made any difference how old the main dash was, I've used UnleashX v543 (2004) and a variety of old dashboards on both a chipped and numerous softmodded machines for years and never had any trouble launching XBMC. What BIOS are you using?

With a modchip all you should need to do is cold boot a disc like HeXEn or AID and, using the specific chipped install options, install a new main dash.

If it is UnleashX the config.xml file should have been set up to launch anything located in E, F or G:\Apps as long as it is in a single level folder and has a "default.xbe". The fact that does not launch even when you click on the default.xbe itself suggests there is a problem with the XBMC folder contents - possibly the skin being used.

You said it was the 2018 version of HeXEn you used. I believe it may be one of a number of 'unofficial' updates of the 2017 original. That was apparently an approved update which refined and added a few things to Heimdall's original HeXEn.

The 2018 versions of HeXEn I've seen have no validity in that respect - they're essentially unique enthusiast made updates based on the original or the 2017 update found on various other Xbox forums. No quality control and less users to report back any problems.

So that returns us to my original suggestions ie. that the XBMC version on the 2018 disc you have is borked and you need to find a new source, preferably not on someone else's installer disc.

Goggle "XBMC4XBOX v3.5.3 Download" and very likely the top of the list will be the place to get it.

If you can't find an original version of HeXEn then look for "Auto Installer Deluxe v4.53 Full/Lite" instead (my preferred installer). Burn the ISO to DVD-R and, as said, use the chipped options from the main menu or one-click install and all should be good with your dash set up.

I would recommend you use a clean HDD if possible rather than overwriting for this so there are no leftovers from whatever has been done before. After installing the dashboard use XBPartitioner v1.3 (must be this version) to check the extended drive(s) F and G, if used, have been formatted correctly. That is dependent on the HDD size.