Page 1 of 2

Xbmc4xbox launch failure

Posted: Sun Sep 23, 2018 7:52 pm
by tonnio59
Hello everybody,

I just decide to use my old Xbox before Manu years of sleeping.
The problem is that when I want to use the Xbmc app (old version) the app freeze at the startup display.And then the only solution is to restart the Xbox.
I tried with the last version for the same result...
For information, my xbox is sotfmoded with unleashx v0.37.

Dors anyone can help me?

Thanks for your help.

Re: Xbmc4xbox launch failure

Posted: Mon Sep 24, 2018 4:06 pm
by Coldly-Indifferent
UnleashX is not a softmod it is the main dash you are using.

Why XBMC is failing to launch could be down to many reasons but if the UnleashX main dash boots OK, as it sounds as if it must be, then any XBMC download, correctly installed as an app in Apps, should be bootable from the main UnleashX menu > Applications.

So where is XBMC installed? Screenshots of your E:\drive and E:\Apps or wherever XBMC is installed could help.

Have you tried launching XBMC direct from the UnleashX file manager? Find the "default.xbe" in the XBMC folder and click on it. XBMC should launch.

Re: Xbmc4xbox launch failure

Posted: Tue Sep 25, 2018 8:22 pm
by tonnio59
Thank you for your assistance ;)

Yes I confirm that everything is fine with the dash (other applies and games work correctly)
Yes I tried to launch the app with the default.xbe for the same result.

You will find below pictures of my E directory, hope it helps.


Re: Xbmc4xbox launch failure

Posted: Wed Sep 26, 2018 12:38 am
by Coldly-Indifferent
There's nothing obviously wrong that I can see which would cause the problem. Although I'm wondering what that separate default.xbe is doing in E:\apps I don't think it would cause XBMC not to launch. But if you were mistakenly trying to launch XBMC from that, whatever it is, it would explain why it didn't work.

XBMC launched using its own default.xbe left inside the XBMC folder, via the file manager ie. E:\apps\XBMC\default.xbe should boot wherever it is located on the Xbox. The fact it is not suggests a problem with either the XBMC download/install or a settings issue, possibly a dodgy skin file. If you installed the current XBMC (v3.5.3) over the old one you mentioned the skin it was using might still be the one selected. If it is broken then that might explain things.

Simple solution: download another copy of XBMC preferably from a different source. Put it in a temporary file on E:\ or F:\ and try launching that from the UnleashX file manger.

Also try clearing the contents of the E:\CACHE file that can sometimes interfere with programs launching properly.

This is a bit far fetched but as you also have a F:\drive; is there any chance you have another XBMC copy in there?

If you have two or more copies of XBMC the default.xbe will be named the same ie. XBMC. Therefore when you install the new one in E:\Apps I think the UnleashX dash menu will only list the existing one in F:\Apps or F:\Applications as it was there first. You may have not been launching the newer XBMC install.

If it still does not boot I'm sure others here might be able to work out what is going on if you post the XBMC log file (just copy it and change the extension to .txt) or at least the relevant part which might show what element is causing the crash.

Re: Xbmc4xbox launch failure

Posted: Wed Sep 26, 2018 8:26 pm
by tonnio59

So the lonely default.xbe is dealing with XBpartitionner 1.0 LBA48 patch V3.
There is only data and skin files for UNLEASX in F directory but just to be sure I format it.

I erase the E: cache, created a new folder on E and transfer inside the XBMC 3.5.3 from a different source.
I tried to launch bot default.xbe file thanks to the unleash file manager and unfortunately it's stil not working...

You will find attached the xbmc log from the old and new version.

Hope you will find something interesting...

Re: Xbmc4xbox launch failure

Posted: Thu Sep 27, 2018 3:39 pm
by Coldly-Indifferent
Just to be sure: is that xbmc 2 log from the one currently installed in E:\Apps and the other: xbmc log 3.5.3 the one from the E:\temporary folder\XBMC? Am I right in thinking your Xbox is set for French language? Do you have any similar problems launching other applications?

Hold down both thumbsticks (clicked) when launching or booting XBMC. This will cause a screen to pop up asking you if you want to reset your settings (including the active skin) to the defaults.

I doubt that will help but, assuming the copy/download is OK, ensuring XBMC is launching in default mode excludes many of the possible causes of the problem like display region/resolution settings which your TV might not like.

On that matter you might try using AV Composite or SCART (RGB) cables if you're currently using Component.

What I hadn't noticed before is that you have both XBMC and XBMP (Xbox Media Player) in E:\Apps. Xbox Media Player was the very old name given to XBMC so you do have two "XBMC" installations and there is the very, very vague possibility they might be conflicting. Try backing up XBMP somewhere else and deleting/moving it from E:\Apps. Reboot and relaunch XBMC from the UnleashX main menu again.

I see that the F:\drive has only about 500MB free space which suggests it could be quite full. What size of HDD are you using? Have you checked that F:\ was correctly formatted? It can cause weird issues although usually just to F:\. Use XBPartitioner v1.3 and if there is an "ER" against Partition 6 then it has a problem which needs addressing even if it is not related to this XBMC launch matter.

Re: Xbmc4xbox launch failure

Posted: Thu Sep 27, 2018 10:23 pm
by tonnio59
Yes the XBMC 2 is on E:apps and the XBMC 3 is located on E:TEST.Indeed you are right I'm french. No and it's make me crazy, it's the only app which crash like this...
I held down both thumbsticks (clicked) and press but the app still freezing.
I'm currently using SCART cable.

I delete XBMP, restarted and launched XBMC with the same problem.
My hardrive is the original hardrive around 10 go.
All parttion on xbpartioner are good and correclty formated with this app (see attached picture).

Have you seen something wrong on the differents log files?
I saw some lines with some errors.

I found this on the web, what do you think ?

I try to launch XBMC from a dashboard and it does not start (freeze or black screen), why?

If you have a very old BIOS in your modchip, make sure that XBMC's XBE (executable) is patched from DEBUG to RETAIL, as old BIOS's can't run DEBUG executeables. You can patch it with xbepatch or deXBE. If you get same problem again try another build of XBMC, if still same issue follow EvoX FAQ.
XBMC is set as my dashboard, and boots to a black screen when I turn on my XBOX. What can I do?

You can reset all XBMC settings to defaults, by holding down the two thumbsticks at startup. See more here.
If this is unsuccessful, you can force XBMC to start the Error Recovery Mode, which will give you FTP access, by holding down the White and Y button down during startup.

Modchip is mentionned but for my part it's a soft mod so I guess I'm not concerned.

Thank you for your help, I appreciate.

Re: Xbmc4xbox launch failure

Posted: Fri Sep 28, 2018 12:26 am
by Coldly-Indifferent
I found that information too when researching this problem but it applies specifically to chipped machines niche BIOS issues so if your Xbox is definitely softmodded then it does not apply.

The log files really need someone who knows what they're looking for as XBMC will report as errors an item not found just because you're not online or, for example, there's a skin file it wants to use that isn't there any more because the skin was modified or updated. Lots of stuff like that.

I was asking about the regional language settings because an error listed in one of the install version logs shows a problem loading a Project Mayhem III language XML file. But both the French and English ones report the same failing to open so I have have no idea if that is relevant. The other log for the same XBMC reports an error: <programs> tag is missing or sources.xml is malformed. But if that was the problem why doesn't the old log show a crash at the same point too?

When you look at the log from the new XBMC download in the temporary folder the only error reported is the missing guisettings.xml. This is as expected for a first boot as there are no user settings changes made yet. The log otherwise looks normal to me and the fact the XBMC4Xbox splash displays and using the 'safe' boot method gives you that options screen suggests XBMC should have booted OK. Why it didn't.....I'm at a loss to explain.

I hope someone else here can come up with some more ideas.

What they probably will say is redo the softmod with a more recent installer ie. Rocky5's Xbox Softmodding Tools, HeXEn or the final version of SID or AID. It may well be the easiest potential solution if nobody else can explain what is causing the launch problem.

Its your Xbox and if you just want to get XBMC up and running there is no reason to think re-softmoddng won't resolve whatever the trouble is if it is being caused by some quirk with the existing softmod.

But what I would suggest is that if you do this you upgrade to a bigger HDD using Chimp 261812 first and do the re-softmodding on that. If you're curious you could even test the new 'clone' HDD before doing the re-softmod to see if that presents the same problem.

BTW if you're using the original HDD that explains the low free drive space on F:\. Most(?) users do not bother with enabling F:\ when using the retail HDD but I have never read about it causing trouble if you do.

Re: Xbmc4xbox launch failure

Posted: Fri Sep 28, 2018 7:36 am
by tonnio59
Yes I Hope that someone else could find the solution. Before all explanations you provide to me, I don't understand why it still not working...

I was thinking about reinstall the softmod too.
Do you know where I can find Rocky5's Xbox installer or the others ?

For the replacement of the hardrive, I have difficulties tout find a lockable One AT a correct price, that's why I keep the genuine.

Thanks a lot for your time.

Re: Xbmc4xbox launch failure

Posted: Fri Sep 28, 2018 1:24 pm
by Coldly-Indifferent
Most HDDs are lockable; I've probably used over a dozen different ones with softmods over the years from 40GB to 160GB IDE and two 320GB SATA. Only HDD that wouldn't lock was a dodgy 40GB WD from a batch of three which I bought from eBay secondhand. If its IDE or SATA Seagate, WD, Maxtor you can be pretty sure it will lock particularly if it is 120GB or 160GB as almost all models of those sizes/makes are reported as lockable by multiple users.

The only trouble you may have is with the SATA adapter.


Cost, for a usefully bigger size used 3.5" HDD ie. 80GB+ and a SATA adapter, should be under £15/€17 including postage and you can still find used but good condition IDE HDDs of all sizes cheaper.

Just Google Rocky5/Xbox Softmodding Tool or Hexen 2017 Installer Disc. The later versions of SID/AID are now much more difficult to find and/or get but an archive place like Eurasia may have them. You could try Googling SPPV's SID5 Babylon or use similar search parameters and find working links. His Babylon series of installers are essentially updated SID versions.

This hassle finding SID/AID is all thanks to pressure from Nintendo and their ilk recently causing the shutdown of valuable resource web sites like the ISOzone (which actually didn't host any files itself) and the blanket removal of all downloads from other places like eg. EMUParadise which had working links for invaluable tools like SID/AID.

Re: Xbmc4xbox launch failure

Posted: Fri Sep 28, 2018 10:31 pm
by tonnio59

I just find an old Maxtor diamond max plus 9 withh 80gb (6Y080L) memory which belong to a friend.
So I have the possibility to use an old PC with PATA connector on the following days.
As soon as I unlocked and install the softmod, I will let you inform.
I succeed to find a rocky5 version, do you know the "french" version : xcalibur 3.4 JP33 ?
It looks similar than rocky5 softmodding tool

Re: Xbmc4xbox launch failure

Posted: Sat Sep 29, 2018 1:11 am
by Coldly-Indifferent
I just Googled Xcalibur 3.4 - not a softmod tool I'd ever heard of before but it is clearly quite old (2008) installing Krayzie's Ndure 3.4 Exploit. The PDF manual indicates the XBMC version it appears to include is v2 and as you know we're up to v3.5.3 now.

Rocky5's last XSMT update was only last year, I think.

HeXEn 2017, whilst essentially the same as it was when Heimdall created it back around the same time (2008), was, obviously, updated only last year too and if I've remembered correctly has always given you the choice of a Krayzie's Ndure or Kingroach softmod.

Both Rocky5's XSMT and HeXEn 2017 are much more recent packages so are to be preferred for most users, particularly if there are likely to be other people/pesky kids :) using your Xbox. Rocky5 also created XBMC4Kids an ultra safe, pared down XBMC install for just such reasons too.

EDIT 20.09.18

I've just had a look at Xcalibur 3.4 which I downloaded just out interest and looking at its contents I think there is good chance it or an earlier version was what was used for your existing softmod. TBH I found a lot of it beyond my knowledge level and very rudimentary French :).

But of what I did understand it appears that XBMC is required to be set up in a particular way for use. It has a separate folder and an UnleashX config.xml dedicated, I think, to downloading/installing XBMC. It might only apply to XBMC updates or when using it as a main dash, I just don't know. Perhaps somebody else here can explain.

But the bottom line would seem to be that it is more likely your current softmod which is causing the problem preventing XBMC booting in what is now considered the 'normal' way ie. installed as an application in E:\Apps or anywhere else.

Unless you can make sense of the Xcalibur manual then updating your softmod as previously described I think is your best course of action.

Re: Xbmc4xbox launch failure

Posted: Sat Sep 29, 2018 10:17 pm
by tonnio59

Ok for rocky5,I will make the sofmod with it.

Yes you're wright I thing that my XBOX was softmoded with the older version of xcalibur.

If you have understood this, it means that your french is not so rudimentary ;)
My English is rudimentary too ^^

For now I have a bigger problem... I tried to make the softmod with rocky5 on my current HDD to see how it works.
For that I wanted to start with a "default" hdd as if the xbox was new. So I did it...

But I don't checked before if I have a usb key compatible with the XBOX (thanks to my modified remote connector), HUGE mistake...

I tried with all my usb key, event if with old smartphone, numeric camera in storage mode etc... No memory card displayed on the Memory folder...

I guess that I need a usb stick with a low capacity such as 128 mb ?

It will makes me insane!

Re: Xbmc4xbox launch failure

Posted: Sun Sep 30, 2018 5:13 pm
by Coldly-Indifferent
Your more than adequate knowledge and use of English makes me embarrassed to have claimed even rudimentary French language skills. :oops:

Flash drives are a law unto themselves when it comes to getting them to work with a Xbox. Some do, some don't and in all sorts of weird ways too. As long as they're USB 2.0 or a previous USB version and 4GB or less in size they can work. But whether they will is an enntirely different matter.

But you don't need actually need flash drive - you have a working softmodded Xbox already. At least I hope it is still working. You should be able to FTP to it from your PC.

Before you do anything else - what exactly have you done so far? Are you saying you actually removed the softmod (how?) and then tried to use Rocky5's XBST before realising you needed to install the game saves?

Is you'd only waited you could have made things much easier for yourself. Rocky5's XBST package includes an Extras disc/kit with option to update old softmods:-

I tested an earlier version on a SID softmod and once the disc was burned (DVD-R using Imgburn) and it 'updated' SID in under 30 seconds without any trouble.

Alternatively, if you really wanted to go back to retail state first, before doing that you had a working working softmod: you could just have FTPed or even installed the Rocky5's supplied games saves from disc.

Avoiding these sorts of problems and giving you a safety net if things went wrong are the very reason I recommended you worked on a cloned HDD not the original one. Did you make a backup of eeprom at any point?

The horse has bolted now and if the softmod is gone and you don't have that eeprom backup you will need a working flash drive.

Re: Xbmc4xbox launch failure

Posted: Sun Sep 30, 2018 8:51 pm
by Xphazer
Peut-être que ceci pourrait t’aider.


Re: Xbmc4xbox launch failure

Posted: Sun Sep 30, 2018 10:28 pm
by tonnio59
Coldly : Thank you I try to make the less mistakes that I can. But I know that my grammar and conjugation are not so good as I would like.

So yes If I know that I can "upgrade" my sofmod with this easier method I would do.Before doing this mistake, I erased my SC save on my XBOX an replaced it by this which are present on the rocky5 folder.When I launched it, I getted back to my Ndure XCalibur sofmod menu not Rocky5's menu.

It was late in the night and I was tired, so I decided to start over with my default xbox state (without sofmod) and use rocky5.

Knowing that I own Splinter cell and an enhance usb controler,I erase the sofmod and now I'm stuck.

So the compatibility oF usb stick is not so simple. I ordered on Amazon 2 128mb usb sticks but the delivery time is around one month.

Yes I have a backup of my eeprom,in fact I have a backup of all my HDD. I have to save it if I wanted to make a new HDD with HDD maker.
Concerning my original issue it seems that Xphazer have a track...If I understand well it's a problem with the Q directory on the confIg.XML??

Xphazer: Merci de ton aide, donc si j'ai bien compris, il suffirait juste de modifier des lignes dans le fichierconfig ??!!

Re: Xbmc4xbox launch failure

Posted: Mon Oct 01, 2018 12:56 am
by Coldly-Indifferent
I searched here for similar problems when this thread started and wish I'd found that post which Xphazer linked too. It sounds as if it might well have been the same missing advancedsettings.xml > powersave matter. Not sure I understand why it should happen, even with the explanation provided it seems an odd, very niche issue. But that's why I suggested waiting for advice from somebody who could better interpret the logs.

Water under the bridge now, the good news is that with the eeprom you have at least one additional solution available.

The problem with returning the Xbox to retail state is that if it isn't done using the same tool used to install the softmod it can leave stuff behind. That can mean Rocky5's or any other SC game save exploits might still not work although there are other reasons that might happen too*.

You could use the 007 AUF, MA or TH4 exploits instead which, of course, means getting hold of one of those games.

But don't worry about that until you've at least tried with SC again. If Rocky5's SC game saves are still on the HDD that's what you should try first. I'd also try cold booting his Extras disc because there is the possibility that the softmod is still working even if you're back on the default MS dash. Burned discs could still boot if you're very lucky.

One question though: what region is the Xbox set too, PAL or NTSC?

If it is a PAL machine set to NTSC, as most people with PAL Xboxes do, then the problem is you need to use a NTSC copy of SC and the NTSC SC game saves not the PAL ones. I did not have a NTSC SC copy to test but my belief is that when using the game save exploits everything (Xbox/SC game/game saves region) has to be either PAL or NTSC; you can not mix them.

I made exactly the same mistake when I first tested Rocky5's XBST; I forgot my PAL Xbox was region swapped to NTSC and whilst the PAL version of SC boots OK I found that neither the PAL or NTSC SC game saves worked. It kept on bouncing me back to my main dash when I used "Checkpoints".

Just as you did I removed the (SID) softmod to get it back to retails state still forgetting it was set to NTSC. Once on the MS dash there was no way to change it back. However as I was working on a cloned HDD I had the original softmodded retail HDD to go back too and start again. In this case that is not possible unfortunately.

Re: Xbmc4xbox launch failure

Posted: Mon Oct 01, 2018 2:45 am
by Rocky5
I take it you never replaced the softmod save when you removed the SC save? as it’s required for all SC saves. It should still load mind you as it’s hardcoded to install.xbe so unless your excalibur softmod changes these files after a softmod install. ( it won’t exist anymore )

Re: Xbmc4xbox launch failure

Posted: Mon Oct 01, 2018 9:08 am
by tonnio59
Coldly and Rocky5: Ok, so I hope that the issue will not be repeated on the new HDD.

Concerning the SC save and the fact to removed the sofmod, it will possible thanks to the Xcalibur CD which able to get back to a retail state.
The CD warmed me that everything will be erased even saves and sound tracks.

Indeed when I am on the MS dash and on the HDD menu, there is nothing inside it.

But I will tried to burn the extra disk and put it on my XBOX crossing fingers that it will be working...

My machine it's a PAL version, I had in project to activate the HD and for that I have to set my machine on NTSC.

So I choose the PAL SC save when I tested Rocky5 exploit.

Rocky5 : I downloaded files related to the link present on your signature, I guess that know I have everything I need to make things right.
Just a few questions about XBHDM build, I saw that there is a folder with softmod files present in here.
Does it mean that if I created my new HDD with this files, softmod saves will be copied on the HDD ? If it's the case, I will not have to use a usb stick to sofmoded the new HDD?

Thank you

Re: Xbmc4xbox launch failure

Posted: Wed Oct 03, 2018 7:43 am
by tonnio59
Hi everybody!

I have a good news, I have now a new 80 gb xbox HHD moded ;).
I used the XBHMD build of Rocky5 and it's working.

If I want to use the same method for softmod my genuine HDD, should I unlock the HHD before "create" a "new" HDD ?

Unfortunately, I install XBMC4XBOX from the extradisc tool of rocky5 but it's still not working. So it's definitely not my HDD which are in cause, it's an issue about my XBOX.

I really don't understand why it's not working, as far as I remember XBMC worked many years ago..

I think I will try to modify the advancedsettings as mentionned on the link posted by Xphazer.

But if it's working, I read that some people mentionned that after this modification the CPU still at 100%, do you think that it could be damage the machine ?