Page 1 of 1

"Reboot" Freezes Xbox

Posted: Tue Jun 12, 2018 3:21 pm
by Coldly-Indifferent
I've asked about this on other forums and nobody appears to be able to provide an explanation for a rather strange softmod bug I've found when using Softmod Installer Deluxe (SID) v5 series.

It is a long story but the bottom line is this: I have v1.1 Xbox which reports both BIOS and Kernel as 4817. When set to the Xbox's original native region: PAL the softmod works 100%. When swapped to NTSC to make use of the ED/HD resolution options my main dash, UnleashX, menu option "Reboot" freezes the Xbox every time it is used. Otherwise in NTSC mode it works fine.

Initially there was a problem with 'soft reset' ie. IGR in NTSC mode too but that was fixed, possibly by removing the softmods regional XMLs.

Believe me I've tried everything, new SID softmod files, new, clean HDDs, different exploits, different SID versions, re-softmodding, different dash versions. But whatever I've done the result is the same: use the main dash "Reboot" option under NTSC and the Xbox freezes.

However still in NTSC mode, used as apps UnleashX, EvoX and XBMC4Xbox dashes all reboot to the main dash no problem. It is clearly an UnleashX main dash issue.

The fix that worked and I'm going with is that by sheer luck I have another v1.1 Xbox with BIOS shown as 4817 but Kernel 5838. I cloned that HDD and locked it to the problem Xbox and it works 100%. I also found out later that if I used the super old SID v3.1 version I have that too installs a 4817 BIOS and 5838 Kernel installation which resolves whatever is the problem.

This appears to be a niche, possibly unique regional(?) 'bug' which must have something to do with the combination of Kernel, BIOS, SID(5). I can find no references to anything similar in old forum posts anywhere.

Not really understanding softmod BIOS and Kernel in general and compatibility matters not at all I can't begin to explain this and why it just affects "Reboot" in NTSC mode and nothing else. It just seems so niche.

Can anyone here help explain this or suggest what the trouble might be? As said I'm not looking for a fix, I've got that sorted, what I'd appreciate is an explanation and, if possible, at a level I will be able to understand. :)

Re: "Reboot" Freezes Xbox

Posted: Thu Jun 14, 2018 6:02 am
by professor_jonny
being it is a 1.1 I would suggest the fix would be to tsop flash it.

if you are reluctant to solder a conductive paint would be an idea.

Re: "Reboot" Freezes Xbox

Posted: Thu Jun 14, 2018 1:25 pm
by Coldly-Indifferent
AFAIK I know it is not a softmod issue per se, it is a combination of softmod, softmod version, kernel and BIOS which produces this niche NTSC only bug.

Chipping or TSOPing are indeed likely another solution as the BIOS used would almost certainly not exhibit the same problem.

But as I said, I have a fix, using a very old SID version or using a Chimp cloned HDD from the other v1.1. Xbox. Both solutions worked fine.

What I am more interested in now is an explanation for the problem: Why only on this particular Xbox? Why of all things is just Reboot affected? Why does it only affect Reboot in NTSC mode when in PAL everything works 100%? It just seems so random.

Re: "Reboot" Freezes Xbox

Posted: Thu Jun 14, 2018 4:52 pm
by Rocky5
What kernel version is it? as there is a compile error with a specific kernel in NKPatcher if flicker filter is enabled during the compile process.
( I disable it so it doesn’t effect my softmod as you know )

So the error will be due to a section of memory being overwritten incorrectly with a new function or call.

Re: "Reboot" Freezes Xbox

Posted: Thu Jun 14, 2018 11:05 pm
by Coldly-Indifferent
As said in my OP both Kernel and BIOS were reported by all dashboards UnleashX, XBMC and EvoX as 4817.

Now, using the older SID version re-softmod or a Chimp 261812 cloned HDD from my other v1.1 Xbox, also softmodded with the same older SID, it is now reported as BIOS 4817 with Kernel 5838 and all working correctly, including Reboot, in both NTSC and PAL states.